'check your code' button doesn't check code in mobile browser

Hi there,

I’ve been doing the freeCodeCamp lessons for a while now on my mobile phone without logging in (couldn’t use Google OAuth on my Opera Mini browser). I had to switch to Chrome to do some of the main certification projects. Didn’t know the lessons are saved to our accounts until recently, so I’ve been trying to redo my old courses (those Learn this by building that exercise) on Chrome but I wanna ask if it’s really compulsory to do the practice exercises again while logged in to receive a certification as I don’ t wanna waste time.

And I’ve discovered that the Check your code button doesn’t work on the mobile browser so one is unable to move to the next step of the exercise without having to go select manually. Is that a browser or fcc platform problem?

I would like to hear a response please. Thanks.

I have Safari on my phone and it works. Can you give details on what browser you have going to this site https://www.whatismybrowser.com/detect/what-is-my-user-agent/ and pasting here the result?

The only thing mandatory are the certification projects, they are clearly marked as such
image

1 Like

I use Chrome and Opera Mini on an Android device and the button doesn’t work on both like on a PC. It only changes the focus of the page. If it had worked before, I would have known earlier that the lessons were not been submitted.

The only thing mandatory are the certification projects, they are clearly marked as such

That’s a relief.

Thanks.

@ilenia Please, can I get a response to the problem of the button not working on my browsers?

And an update is that I tested with the Brave browser which I have installed too, it works. Though, the button still doesn’t work on Chrome and Opera Mini as stated before.

I use an Android 8 phone, the Chrome version is 70. The version of the Opera Mini is 60. Javascript is also enabled. I have cycled through the settings in the browser but came up short on what could be the cause.

What could be the problem?

Thanks.

I don’t know, I can’t give you an update.

I tried to ask you more infos, but you never provided your user agent

Sorry, couldn’t get through because it was blocking my IP Address.

But I’ve been able to .

Here:

Mozilla/5.0 (Linux; Android 8.1.0; Infinix X624B) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.110 Mobile Safari/537.36

At this time it has not been possible to reproduce it. You can report it as a bug on the issue tracker, including your user agent

Thank you for helping make FCC better. Bugs can be reported as GitHub Issues. Whenever reporting a bug, please check first that there isn’t already an issue for it and provide as much detail as possible.

:cry: Okay. Guess I will stick with the Brave browser for the meantime.

Thanks for your time.