CodeAlly not running

I’ve been trying to start courses in the relational database certification. I’ve made a Github account and tried to run CodeAlly to start the course. Unfortunately, I just get this pop-up instead:

I’m not sure how to fix this. If anyone could help me out, I’d appreciate it. Thanks

I presume you tried again and keep getting this message @rachel.puvvada? I’m not sure what the problem is. Perhaps some browser security settings or something. Do you see anything in the dev tools that might help? Maybe some errors in the console or some failed network requests.

You could try another browser - not sure what that would do, but its something to try. What browser and version are you using?

Yup, that’s right. It’s the same message every time even when I try different courses within the relational database certification. Sometimes, I will click ‘run CodeAlly’, and there will be a blank screen. I refresh the page and am taken back to the ‘start the course’ page.

I’m currently using Chrome. I’ve checked to make sure third-party cookies are enabled as well.

I’m not sure what dev tools are or how they could help, so if you have advice, I would appreciate it.

Thanks!

I would give a different browser a try first if you haven’t already.

In firefox and chrome, you can access the dev tools by right clicking on a page and then click inspect. It will bring them up - at the top are a bunch of tabs that include console, network, and storage(firefox)/application(chrome). The console and network tabs are where you might see some errors or failed network requests. You don’t need to look at those, but it might help if you share any problems you see.

Another thing you could try is to clear all your browser storage related to codeally. In Chrome, go to CodeAlly, open up those dev tools, and go to the application tab. On the left, there’s a storage area with local storage and cookies in it, among others. One at a time, go through the handful of items in that storage area, expand the tab if needed, right click the codeally domain and clear everything for that domain. Then go back to the relational database course and try again - you will need to re-login to codeally when you get there.