[COLLATION] Completed and Submitted Challenges Not Recorded

same problem here, I have tried different browsers and logging in and out, but check progress keeps deleting in Safari and Chrome.

I had been solving problems and my progress was being saved for some time. but starting from some time like 2 weeks ago my progress stopped being saved and I am faced with same problems even with my answers written on it. and I have to press next again and again until I find an error stating a solution is not given for the current problem. that is how I know where I left off last time. but if I leave and try again I am back at where I was the last time again. even the lists that are marked on the main page are not being updated no matter how many more problems I solve. I tried logging out and logging in again but it didn’t change anything. can someone help, please?

1 Like

Hello, I keep having issues with the progress on HTML and html5 course. I have only started, but every time I achieve some progress it will delete a few minutes later. Connection to the internet is good and the browser I use is safari. Every so often just deletes any record of progress, so I constantly have to repeat what I have previously done. Any ideas on how to correct it? thank you

Hi there. This is similar to some recent posts, but I think not identical.
In a nutshell, every time I use freeCodeCamp, I do 1-2 challenges before my progress stops saving. I can still submit challenges and move on to the next one, but the progress bar stalls at a certain percentage even as I keep moving on and submitting challenges, and the checkmarks do not appear on the course progress when I check later.
Around the same time or a bit after, I usually get a warning that ‘you appear to be offline - your progress may not be saved’.
To be clear, I am always connected stably to the Internet when I get this warning (and I have checked this carefully). I have also disabled all add-ons from running on the site; tried using a private window; tried a different browser. I have only ever made one freeCodeCamp account and I always log in the same way. I get the same problem no matter what, and at all times of day.
Any suggestions? I have pretty bad hardware, could that affect things at all?
Thanks for your help.

Welcome there,

I do not have a solution for your problem. We have seen a few similar reports, but there is not enough information to get to the bottom of the issue. It affects a small number of Campers, and our general advice is usually:

  • Use an up-to-date browser (I recommend Chrome for the most reliable experience)
  • Disable all browser extensions with access to freecodecamp.org

After all of that, it might do good to flush your browser cache, and maybe even your DNS cache. For me, on Windows 10, that usually involves:

  1. Open the integrated terminal
  2. Run this command:
ipconfig /flushdns

Just to gather more data: What system/workspace do you use?

  • Operating system
  • Browser (your daily driver)

If your hardware is quite old, I might suggest trying a hardwire internet connection (ethernet).

Any more information you can provide could be helpful. Thank you

1 Like

Hi, thanks so much for your reply. I hope this helps to work out what might be going on.

I’m using (up-to-date) Firefox portable on Windows 10. (I also tried in Edge just in case and had the same experience.)

My hardware is not so much old as bad - very limited storage and quite limited memory for the OS. I’ve never had any problems using a wireless Internet connection on it, however, and generally get decent speeds.

I’ve tried the browser cache previously but I’ll flush it again, and also the DNS cache, and let you know how that goes.

Thanks again for your reply. Sadly, none of this worked for me; however, since writing my last reply I happen to have switched to Linux, and everything now seems to be working just fine, using Chrome on Linux. Go figure.

My Windows 10 was a bit out of date - perhaps that had something to do with it somehow?

Anyway, if anyone else has the same problem, I’d be interested to hear whether switching browser or even OS works for you as well.

Edit: it looks like I accidentally replied to the whole post instead of your response last time - sorry about that.

Congratulations, you got the best of both worlds, FCC is working for you AND you are running Linux!

2 Likes

Every time I log onto freecodecamp via GitHub my progress is erased from 28/28 html 25/43 CSS to 22/28 html and 0/43 css…

I’ve logged in and out several times, sometimes when I log in all of the progress is erased…

Alright so it appears after trying to log out to verify 1/43 CSS it showed initially 0/0 on all courses upon log in… I logged out again and this time authorized with Google, GitHub and GMAIL are the same email address, and im greeted with 22/28 html and 1/43 CSS… still somewhat frustrating as I just completed all 28 html and 25 CSS…

Does your Github account have a different email address than your Google account?

1 Like

No - they have both been tested via safari and chrome-canary as well. Initially when trying to authorize via Safari-github it showed 0/0 on all classes, I allowed cross-website tracking and it appears to be synced with canary now.

-Edit: Do I need to log out after each module? That seems to have been the only thing that has caused the server to save the course completion.

haha… yeah so I tried going from 24-28 on HTML and after logging out then back in it has reverted from:
28/28 html

to,

24/28 html :slightly_smiling_face:

So close… tried logging out after every single module in html, and now it won’t even let me complete step 28/28 without it properly saving… any ideas? would really like to knock this out over the next couple weeks and it’s beginning to look like I won’t be able to at all.

edit- is it because im not donating the 5$ upon completion?

For anyone interested the only apparent solution I’ve found is using chrome-canary as opposed to safari. I have been logging out and back in after every 5-10 modules completed. I will gradually increase the number as I regain trust in the capacity to update to the Server.

I am working through the challenges/tasks. However, every time I log out my progress is wiped out?

I am working through the Javascript course, I use both my Macbook Air & also my iPad to work through the steps. I notice they are never synched at the same lesson, the most recent lesson that I finished? I noticed today, both devices seemed to have jumped back 4 or 5 lessons too.

I am using the same login, (my google login) on both machines, so how can I keep my learning progress in synch & at the same lesson across the Macbook & iPad please?

1 Like

the button to bring to last lesson I think is relying on local storage, but you can always go to the challenge to do from the list of challenges

I have posted about this problem also some weeks ago, but I can’t find my post.

Are the developers aware of this issue?

It’s best to stick with one device until this problem is solved because otherwise you will lose lesson already completed.

I hope they can fix this because freecodecamp is awesome and is about to change my life.
I so wish I could take FCC with me on my iPad!

you can, at the end the only thing that matters for the certificates is the projects, if a challenge is not completed it doesn’t influence you taking the certificate or not