[COLLATION] Completed and Submitted Challenges Not Recorded

Yes I can take it with me and if I can complete certificates on my iPad that is also nice, but I cannot continue on my iPad where I left off on my Mac, and if I find the correct exercise anyways and still continue on my iPad, the lessons I already completed on my Mac are often gone when I return.

We’re trying to make FCC aware of a bug in the hopes they can fix it. I assume it’s not supposed to be like this.

But thanks for pointing out that we can still take certificates on the go.

We’re aware of what’s going on. If it’s a bug, fixes take time.

1 Like

Sounds great! thanks.

If it helps further to narrow down the bug:
All 12 completed lessons on Debugging are now all showing uncompleted.
8 of the 32 completed lessons on ES6 is showing suddenly showing uncompleted.
8 of the 10 Managing Packages with NPM lessons are also wiped.
All my 111 Basic lessons are still displaying completed. No issues there.

I wonder if the issues comes from me taking several of the ES6 lessons more than once, to better learn the material, but I also did that many times during the 111 Basic JS lessons and there are no issues there.

I no longer use FCC on my iPad, as this was clearly causing these issues where lessons taken on my Mac were suddenly showing uncompleted, on my Mac. And lessons were also not getting synced between iPad and Mac. So I stopped using iPad on FCC even though I would love take FCC with me on the road.

Last night when I tried to enable dark mode through freecodecamp.org settings , the page froze and I lost all of my progress. Per the forum suggestions, I tried the method of signing out and signing in using github with no success. I also tried signing out and signing in using only my email address and the code, again with no success. I tried both again this morning with no success. Could you please help me resolve this and regain my progress?

Username: @saltpepper1

Sign-in method: Github

Last completed challenge: Applied Visual Design - Set the Font Weight for Multiple Heading Elements

If you are unable to log in or keep getting “we cannot reach the server…” it may be that you have a duplicated account. To solve this issue you will need to write to support@freecodecamp.org.

Find more support FAQ’s here:

Thanks for the reply. I am able to log in, and am now simply continuing my progress from where I left off. Unfortunately none of my past progress is saved, which is what I’m hoping to fix. I’ve emailed support@freecodecamp.org

I completed the RWD certification in 2019. I was also somewhere through the Intermediate JavaScript Scripting and completed some of the JavaScript library lessons as well. I’ve checked in today to review my progress, and nothing is appearing on my account. My certificate is not there. It’s possible I’ve logged in with the wrong email address, but I put the link to my certificate on my LinkedIn profile and it’s still valid.

Is there an email address or somewhere I can send some links to, so that I can figure out what happened to my account?

you can try to write at support@freecodecamp.org

but before maybe try to log in with a different email address, it may ne that you are logging in with the wrong one

it may also be that you are logging in with the right email address but have a bug for which a second account has been created to an email address already in use - for which the only way to solve is writing at the email address above

Currently busy with Responsive Web Design, Basic CSS.

I’ve currently made it to step 12, Add Rounded Corners with border-radius.

But my progress has for the second time today not been saved. This happened when I initially logged on, completed the first 7 steps (Import a Google Font) Where I then clicked the link for Google Fonts onto a new tab. When returning to the tab of FreeCodeCamp, my page was reset. I then went back to the Courses page and saw everything was reset back to step 1.

So, I then redid everything back until Step 12. Suddenly, I got a warning from Safari that the page was using a lot of memory. Which was also frozen for a few seconds. The page then refreshed, with my progress reset onto step 6; even though in the attached image you can see I had already worked up onto step 12.

Just thought I’d share this bug. Because when I completed each step, it gave me the confirmation with a checkmark.

note that the modal with the checkmark is just saying that you have passed the tests, to save the progress for the challenge you need to press “Submit and go to next challenge”

It is also possible that there is something going wrong with the connection to the server but I wanted to clarify that one at least

hi, I’ve made significant progress in the last 14 days but it doesn’t show in my current challenge progress page. Don’t have links to show proof.

A) Were you signed in?

B) What ‘challenge progress page’ are you referring to?

Luckily I just started this course, but I lost all the progress I made in the past hour. Specifically, I was about 1/4 into the “Basic CSS” course but lost all progress back to 13/28 in “Basic HTML”. If this is a common occurrence, it’ll definitely deter me from continuing.

HI @todes !

Welcome to the forum !

I am sorry that you are experiencing issues.

I moved your post over to this thread.
If you can read through the original post at the top and try the steps suggested that would be helpful.

Thanks!

1 Like

Hi,

My Progress got deleted or somehow doesnt show up.
I completed Basic html Basic css and every exercise in applied visual Design up to @keyframes animations. Is there a way to Update the Progress on the Site since ist got deleted/somehow disappeared?

Thanks for your reply

Could you please read and answer the questions in the first post of this topic?

I will merge this topic there to keep everything together, we are investigating on the issue.

To answer your question, it is not possible to update the progress other than completing a challenge, but know that the only thing you need to complete to be eligible to claim the certs is the 5 projects at the end of the cert curriculum.

Challenges affected:
Basic Html-all challenges
Basic css-all challenges
Applied visual design-Every challenge up to 1st @keyframe exercise

User Agent :
https://developers.whatismybrowser.com/useragents/parse/?analyse-my-user-agent=yes

Im accessing freecodecamp mainly on my macbook, sometimes on the iPad i Used to Type this message.

Location: Germany

Thank you, for sharing this. However, you have not shared your user agent. You have just linked to the same resource in the original post - I am unable to see yours from that link

Your user agent should look similar to:
Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/92.0.4515.159 Safari/537.36

Would you mind editing your post to include your user agent?