D3 visualisation axis failing test

Hello FCCers,

I’m working on the D3 scatter plot project, and I can’t get the test to pass for lining y values with y locations, the test fails even the alignment looks right. What’s causing this?

Here’s the link to project: https://codepen.io/rosezmmm/pen/VweObea?editors=0010

Also, it seems odd my y-axis ticks are at values such as “36:57”, “37:12”, how do you customise the ticks for Dates to start at 10s (e.g. “36:50”, “37:00”)?


I see that your ticks are customized and that you’re passing all the tests so I guess that you managed to solve all the problems, right? :slight_smile:

Is it showing all pass for you? :astonished: from what I see here I can’t get through test case no.8

Maybe try hard refreshing the browser, because from what I can see everything is fine.

Regarding test number 8, it should be passing for you, take a look at this:

The circle on the scatter plot that I highlighted is a perfect candidate for manual testing because it has a round value. It clearly has a correct value :wink:

Thanks, that’s helpful to get me out of the mystery!

Yes, it looks like a browser issue, I tried opening in Safari and it’s showing all good, same as you got on the screenshot. Previously I was using Opera and Chrome which both showed me the same issue.

However, I’m quite certain it’s not cache issue, as I tried:

  • clearing browser cache
  • opening the pen in another computer (Chrome and Firefox )
    both still shows me this, which is why I opened the post.

On the other hand, the data viz certification took the link submission as pass :slight_smile:

As FCC recommends Chrome / Firefox for optimized testing suite experience, I’m just very curious now what’s causing the visualisation to stuck at this in these two browsers.

I’m using Chrome and everything works fine.

What’s also strange is that for you left axis shows different values than it does for me.

Honestly, I don’t know what might be the problem here :expressionless: