Error trying to seed db on local freeCodeCamp clone

I’m trying to set up a local project of freeCodeCamp and I followed all the steps with no problems, but when try to run pnpm run seed I got this errors:

I used this command to run mongo:
brew services start mongodb-community@4.2

I also tried with this command:
mongod --config /opt/homebrew/etc/mongod.conf --fork

Both commands were taken from here: Install MongoDB Community Edition on macOS — MongoDB Manual

I followed this guide to set up the local project: Contribution Guidelines |

My project is cloned in another disk, this is the pwd result:

Hello there,

I have seen that error as well, but it went away after running pnpm i and trying again a few times.

Hope this helps

1 Like

Not luck yet, I tried removing the dependencies and reinstalling them again, but nothing.

I added ./ at the beginning of the import path and it finds the file now, but the error is not this:


I fixed it, just to be able to use the seed script I didn’t used the import line for the image, I manually used the const declaration in the file and it worked. Then I just did git restore .

Just if this helps to someone having this same issue.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.