freeCodeCamp Setup Issue

I am trying to setup it on windows 10 via wsl2. I have followed every step of the guide provided. But I am stuck on the ‘pnpm run seed’. Its showing this error. On typing mongod --version, its also showing the version and also mongo is getting added in docker as container.So, everything else up till this is done properly but ‘pnpm run seed’ isnt working.

Try running pnpm run create:config before pnpm run seed.

Thanks but still…

devbhuva@DESKTOP-UHU4NV9:~/freeCodeCamp$ pnpm run create:config

> @freecodecamp/freecodecamp@0.0.1 create:config /home/devbhuva/freeCodeCamp
> tsc -p config && pnpm run ensure-env && pnpm run download-trending

client/src/components/Donation/types.ts:1:49 - error TS2307: Cannot find module '@stripe/stripe-js' or its corresponding type declarations.

1 import type { Token, PaymentIntentResult } from '@stripe/stripe-js';
                                                  ~~~~~~~~~~~~~~~~~~~


Found 1 error in client/src/components/Donation/types.ts:1

 ELIFECYCLE  Command failed with exit code 2.
devbhuva@DESKTOP-UHU4NV9:~/freeCodeCamp$ pnpm run seed

> @freecodecamp/freecodecamp@0.0.1 seed /home/devbhuva/freeCodeCamp
> cross-env DEBUG=fcc:* node ./tools/scripts/seed/seed-demo-user

/home/devbhuva/freeCodeCamp/tools/scripts/seed/certified-user-data.js:6
  _id: ObjectId('5fa2db00a25c1c1fa49ce067'),
       ^

TypeError: ObjectId is not a function
    at Object.<anonymous> (/home/devbhuva/freeCodeCamp/tools/scripts/seed/certified-user-data.js:6:8)
    at Module._compile (node:internal/modules/cjs/loader:1254:14)
    at Module._extensions..js (node:internal/modules/cjs/loader:1308:10)
    at Module.load (node:internal/modules/cjs/loader:1117:32)
    at Module._load (node:internal/modules/cjs/loader:958:12)
    at Module.require (node:internal/modules/cjs/loader:1141:19)
    at require (node:internal/modules/cjs/helpers:110:18)
    at Object.<anonymous> (/home/devbhuva/freeCodeCamp/tools/scripts/seed/seed-demo-user.js:6:28)
    at Module._compile (node:internal/modules/cjs/loader:1254:14)
    at Module._extensions..js (node:internal/modules/cjs/loader:1308:10)

Node.js v18.15.0
 ELIFECYCLE  Command failed with exit code 1.

Looks like you have not installed all the required dependencies. Run pnpm i again.

Sir, Thanks a lot! I have successfully setup the program. :grin:

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.