Gap in Git Bash when run node

I’m trying to use Node.js and I run it on Git Bash but when I run it I got an annoying gap
like this
How to skip it?

What are you trying to do? Run a node app?

Yes When I am trying to run node on gitbush I always get this annoying gap.

Just tried it and I don’t get the gap, but it was acting a little weird… just curious, why run node on git bash and not just regular old powershell ? Is there some functionality you can do on the former that you can’t on the latter ?

If you are trying to run a node app, you need to execute the below command. This is similar to any programming language.


node app.js



@jamesperrin his screen shot shows that he just trying to run a node environment not an app, typing node without any arguments lets you run the node environment in the command line, just as typing python let’s you run the python environment in the command line.

Right, but he said he doesn’t like it when you type node which then puts him in the node environment.

I’m trying to use Node.js and I run it on Git Bash but when I run it I got an annoying gap
like this
How to skip it?

Like what? He wants to get rid of the gap in the CL when running the node environment in git bash, I wasn’t able to duplicate the gap on my system, can you?

The posters screenshot is show them in the Node interactive mode.

Yes, occurs regardless if it’s Node, Python or Ruby. Just typing the language’s name will jump you into their interactive mode.

@Stas761 What versions of Node.js and Git are you using? You can check using node --version and git --version.

I’m not able to reproduce the bug with these versions:

$ node --version

$ git --version
git version

There are quite a few differences:

tl;dr: Git Bash is faster, lighter, less powerful, and more Unix-ey. Some widely-used Linux commands that come with Git Bash, such as grep, touch, and less, don’t work on PowerShell (though I assume it has its own equivalents).

Ah so it’s for using linux bash shell on windows and not git itself as git commands are already available in PowerShell with any git installation in windows.
Anyway in this day and age, I’d recommend installing a linux bash shell which is freely available in the store for Windows 10 (which looks like the OP is using) , one can then switch to a bash shell by simply typing bash in PS, unlike the old days where you had to use cygwin or a HD partition installation of a linux system, this way you not only get a bash shell, but also a full layer to run linux applications.