Git / GitHub Question: Two of me have pushed on the repo?

Git / GitHub Question: Two of me have pushed on the repo?
0

#1

I recently got a new MacBook and it seems like ever since then when I push something to github it says two of me have pushed. For example the picture below:

I have also noticed that GitHub hasn’t been counting my contributions for the last few days so I think that has something to do with it.

Anyone know what I messed up??


#2

Are you using command line?


#3

No I’ve been using VSCode for that


#4

Try using command line


#5

Yes everything worked from the command line, definitely should have tried that first lol. Any idea why it would be different in VSCode? I didnt have the problem before is there some setting i’m missing?


#6

No clue. I’ve not used VsCode and GitHub together. Try a Microsoft Forum?


#7

Sounds good dude. Thanks for your help!


#8

Maybe it’s because your email on GitHub and the email set in your local git config don’t match? The GitHub help page says that it counts contributions when the email used in the commits is associated with your GitHub account.


#9

Yeah that makes sense ill check it out! Thanks