Git Trouble in VSCode in Win10 - Please help!

Hi everyone, please help with this very frustrating issue =

I’m following the FCC Github tutorial, and for the life of me, I CAN’T get VSCode to see git. I have installed GitBash (and GitCMD, apparently), and I have GitBash running well - it accepts git commands.

VSCode, however, refuses to acknowledge that git exists. I have tried the following:

  • Added “C:\Program Files\Git\mingw64\bin\git.exe” to “git.path” in settings.json. Didn’t work. (This is the GitBash path)
  • Added “git.enabled”: true to settings.json. Didn’t work
  • Added the same GitBash path to the environment path in Windows settings. Doesn’t work.

What am I missing? This step shouldn’t be so difficult.

can you clarify what you mean by this? (what did you try that didn’t work as expected)

did you try to run a command that didn’t work?
was there an error message when you ran that command?

1 Like

Hey everybody, sorry for not responding sooner. I appreaciate your willingness to help!

The problem was that, in VSCode, my terminal was defined as “powershell,” and so it did not recognize any Git Bash commands. I had to manually switch the VSCode terminal it to “Git Bash”, and then things started to work. It’s not mentioned in the FCC Youtube course, so perhaps this thread might help others in the future.

Thank you!

1 Like