Guy's I'm having trouble installing Ruby


It said var/lib/pacman/db.lck exists(in windows)

I don’t know how to Delete this one…

Also I have another question,

can I do this on another language like JS.?


sudo rm -f var/lib/pacman/db.lck in a bash command line. Or you manually find that file and delete it. But windows? As in operating system windows? That’s Arch Linux’ package manager lockfile


I don’t know man I just want to accomplish the link below, for my client I think this kind of Promotion (not a prelaunch) + facebook ad’s it will destroy competition…
also can’t find the file I did try it…
is there a ruby for windows ?


What? Ruby is just a language, runs fine on Windows. The bit before that makes no sense I’m afraid.


what do you mean by bit?


The bit prior to “is there a ruby for windows”.

As far as I understand, you have found a thing that’s written in Ruby.

  1. you have tried to install Ruby to run it, and failed.
  2. You want to know whether it can be written in another language (JS).

For 1 is have you followed the instructions on the Ruby website for installing? There’s an installer for Windows, you should just be able to run that and be done.
For 2 yeah, sure.

I think you need to decide whether it’s easier to learn minimal Ruby so you can use that thing, learn enough Ruby to port it to JS, or just Google up some similar JS things and glue them together so you’ve got the same functionality - latter is probably easiest option by quite a long way if youre not familiar with Ruby.


oh you mean the 64x or …
it’s compatible…

I did follow but something happen My laptop has no space so I stop it like (X) then when I open it(after clearing some data Video’s that takes some space) it said that…

that’s basically what I’m doing right now


Have you tried the ruby windows installer?
After install, rails is easy to install via any tutorial.


So you’ve killed the installer before it’s finished and it’s left something on your computer? As in, you get that message when you try to run the installer the next time?

The file in question relates to a specific distribution of Linux (Arch), not sure why you’re getting that message.


yes… hmm that make’s sense all of it is just Linux…