Having trouble with my social media icons


#1

I’ve tried many things but the first two buttons aren’t going to the links the code pen icon is working perfectly any ideas why?? here is the project


#2
  <a href="https://github.com/Salvara4" class="social GitHub" title="GitHub">
    <svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.0" viewBox="0 0 512 512"><path d="M256 70.7c-102.6 0-185.9 83.2-185.9 185.9 0 82.1 53.3 151.8 127.1 176.4 9.3 1.7 12.3-4 12.3-8.9V389.4c-51.7 11.3-62.5-21.9-62.5-21.9 -8.4-21.5-20.6-27.2-20.6-27.2 -16.9-11.5 1.3-11.3 1.3-11.3 18.7 1.3 28.5 19.2 28.5 19.2 16.6 28.4 43.5 20.2 54.1 15.4 1.7-12 6.5-20.2 11.8-24.9 -41.3-4.7-84.7-20.6-84.7-91.9 0-20.3 7.3-36.9 19.2-49.9 -1.9-4.7-8.3-23.6 1.8-49.2 0 0 15.6-5 51.1 19.1 14.8-4.1 30.7-6.2 46.5-6.3 15.8 0.1 31.7 2.1 46.6 6.3 35.5-24 51.1-19.1 51.1-19.1 10.1 25.6 3.8 44.5 1.8 49.2 11.9 13 19.1 29.6 19.1 49.9 0 71.4-43.5 87.1-84.9 91.7 6.7 5.8 12.8 17.1 12.8 34.4 0 24.9 0 44.9 0 51 0 4.9 3 10.7 12.4 8.9 73.8-24.6 127-94.3 127-176.4C441.9 153.9 358.6 70.7 256 70.7z"/></svg>
    </a>

  <!--CodePen-->
  <a href="https://codepen.io/GentlmnSteez/"='_blank' class="social CodePen" title="CodePen">
   <svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.0" x="0px" y="0px" viewBox="0 0 48 48" ><g>	<polygon fill="none" stroke="#455A64" stroke-width="4" stroke-miterlimit="10" points="41,18 24,7 7,18 7,30 24,41 41,30 	"></polygon>	<polyline fill="none" stroke="#455A64" stroke-width="4" stroke-miterlimit="10" points="7,18 24,30 41,18 	"></polyline>	<polyline fill="none" stroke="#455A64" stroke-width="4" stroke-miterlimit="10" points="41,30 24,18.2 7,30 	"></polyline>	<line fill="none" stroke="#455A64" stroke-width="4" stroke-miterlimit="10" x1="24" y1="18.1" x2="24" y2="8"></line>	<line fill="none" stroke="#455A64" stroke-width="4" stroke-miterlimit="10" x1="24" y1="40" x2="24" y2="29.9"></line></g></svg>
  </a>```

#3

Due to cross origin policy and sandboxing u wont be able to link something to codepen .Try adding target="_blank" to the <a> tag ;


#4

if you look at the code pen link it actually works the way its written but I do the same to the other links and it doesn’t work


#5

Codepen does not link to any other site on its page but it surely links other codepen projects(links to itself).For other sites like github you will have to use target="_blank"


#6

yeah I saw I was missing the target= part thank you