How-to-npm remove dependencies

How-to-npm remove dependencies
0.0 0

#1

Hello, I’m struggling with the penultimate npm tutorial.

I ran ‘npm rm @linclark/pkg --save’ to remove the dependency, and when I run ‘npm ls’ it shows ‘(empty)’, so it seems like the removal worked. However, when I run ‘how-to-npm verify’ it says that there are still deps lying around. Does anyone know where they might be?

Thanks


#2

Congratulations for getting as far as you did because, to be honest, how-to-npm is almost unusably buggy. I really wish I could offer more help, but there have been a number of show-stopping bugs in that package and I think the only solution is to rewrite it almost from the ground up.


#3

Haha thanks, it does seem like a lot of people are having problems with it. I was just so close!


#4

Well, I’ve got to number 10 on this, although I had errors on 8 and it still verified. Not finding this useful at all, don’t really know what I’m doing and why! Also the package is very buggy. Maybe it should be removed from the syllabus, there must be better ways of learning what npm is and how to use it. Think I’m better off spending the time looking for them than trying to get through this.


#5

I feel like I only started understanding npm when I started actually making backend apps. I agree the tutorial package wasn’t very useful- it just felt like I was typing in random commands without actually understanding what they did or what I was trying to accomplish.


#6

A bit late, but I figured out a solution. Don’t add the version number at the end of the dependency.
ex. npm rm @linclark/pkg --save