How to open an FCC exercise which was 'saved' to local drive

Hi there, This is a newbie q’ for sure.
I have certain FCC exercises that I ‘saved’ via the FCC GUI and am wondering how I open them again and have them readable instead of one long string of text.
I was saving certain exercises for reference, but didn’t need to check any until now.
When I open them with editors, they are single line of text.
I’ve tried Notepad, Notepad++, Komodo
Thanks,

Welcome @ReallyWant2Learn!

Not sure what operating system you are using (but I assume Windows). I use Windows and can open the files created using Notepad and Notepad++.

Hi, and thanks for the reply.
I am using Windows 8.1.
Yes, I can open the files with above mentioned programs, but all the text is on a single long line.
Like the program is not handling the end of line characters properly.
I must be missing something, since if you open these files, you should be able to see your program just as if you were working on it. With each new line on a separate line again.

I thought for sure Komoto would open it correctly, since it is an advance featured editor and can handle .json files as well.

So, in short:
NotePad++ and WordPad will open my .txt files and show the lines normally, so you can work with it.
Komoto will open and show .txt files normally as well.
NotePad, will not show each new line on a new line. This is probably because it is a simpler program?

NotePad++ and Komoto will open the .json files, but will not handle the ‘EOL’ properly. The whole file shows on one line.
I’m not noticing any settings that might effect this in either program.
Any suggestions.

The files downloaded are not JSON files. They are simple text files. Can you take a screen shot of the file you open that is all of one line in NotePad++?

Thanks.

Hi again,
Here is a simple screen shot of one of the files.
Somehow all the files were being saved as .json back in August.
I’m now seeing that the files are being saved as .txt.
Not sure why.
Here is one example file: The info goes off the screen to the right, but enough to see what’s happening.

@ReallyWant2Learn OK, I thought you were referring to the newer version (.txt) that was recently implemented about 5 weeks ago from a fix I implemented.

Unfortunately, the JSON version will be in a single line because it is just a large string. You can check this topic for an app a user created to convert the JSON version into a properly formatted text version.

The newer version downloaded should open up like normal in Notepad and Notepad++. Please let me know if the newer version shows all in a single line like the JSON version does.

Hi there, Thanks for the response,
I was wondering if it was me or if something changed in the GUI.
Ok, so there was a change. Thanks, that helps explain things for me.

I checked out my latest downloads for their results:
NotePad - opened with one long line of text.
NotePad++ - worked fine
WordPad - worked fine
Komoto - worked fine

I also checked out that suggested post you mentioned. It works GREAT!
I converted all my .json files over to .txt files for easier reference.
I would definately recommend that to others.

I can put this issue to rest now, LOL.

Shout-out to @leanSeverino1022 for his work on this.
Here, you can use the tool. :slight_smile:

https://fcc-solution-parser.herokuapp.com/

link to github repo - https://github.com/LeanSeverino1022/freecodecamp-solution-parse

Starting in Windows 10, Notepad was updated to display LF as CRLF and shows the multiple lines.

1 Like

Hi there,
Wow, nice job tracking that down.
I"ll put this in my notes as well.
Currently, I’m still on Win 8.1. May or may not upgrade on this HP Envy laptop in the future.
Thanks for the update.