Json edited with notepad and back to json

Ok so, I wanted to edit a .json file, and it asked me how do you want to do that so i pressed Notepad, after i was done editing it, it was a notepad and so the program wouldn’t work at all. So i just want to know how to convert it back to json, I ve tried to change it to ‘‘Options.json’’ (options being the file)(i guess typing .json in the end is what i am trying to say)and it didn’t work. If someone knows please help if not its ok i will prob format my pc so it is back to normal. Thanks.

Are you possible that there aren’t any syntax errors in your edited JSON file?

1 Like

pp I think it is correct.

No. The actual contents of the file.

1 Like

Yeah i am pretty sure that there are no errors in that edited json file since it worked on a different pc (it pretty much is a filler section where you type your name and stuff)

I agree that there is likely an issue with the json file. You might want to switch to a editor with some kind of linting or use an online validator. Try copying your json over to that site and see if it can find any errors.

1 Like

Just did it and it said that it is correct

I dont know anymore…

Great, now you have ruled out issues with your source JSON. That means the problem is likely in whatever code is interpreting the JSON.

What exactly is the problem or error you are having?

1 Like

So i run the program from cmd the program is in python 3.7.4 so i type in cmd to run the program and it says that it doesnt find options.json and i think thats because it is a notepad now and not a (white note) icon ( i guess i dont know how to convert it back to a json. If u want exacly what cmd says i can sent it.

I suspect that the file just isn’t where the program expects the file to be.


that what i was thinking i will check it again but i am pretty sure it. Anyways i try to check it validly.

Yes…I dont know i donwloaded some programs to open the json file thats why the icon is like that but i tried it with the notepad already and it didnt work.

From the command line, list the files in the directory. See if Options.json is there. If it is, check the permissions on the file and make sure that they are appropriate. I’m assuming that you have tried opening the file from a text editor and that it opens and appears correct?

1 Like

Yes, if notepad is a text editor.

how do i go to the command line?

i deleted notepad through system32 and it worked thats guys fro your time. Dont really know what will happen now xd.

Whenever I use a general purpose editor and not a text editor made for programming, I make sure to:

  1. keep the file extension

  2. validate it

  3. set the text encoding to UTF-8 and not the system text encoding

  4. If it’s available as an option I’ll set the line endings to Unix

with all that and the file in the right location. I’ve avoided problems.