How to Use package.json Challenge Help!

I cloned the glitch repo, edited the package.json file and paste the app url on the submission but still receiving “package.json should have a valid “author” key”
Please help.

1 Like

This is how you are suppose to write “author”: “Jane Doe”,
also click on show then copy paste the url to send it to freecodecamp

“name”: “hello-express”,
“version”: “0.0.1”,
“description”: “A simple Node app built on Express, instantly up and running.”,
“main”: “server.js”,
“author”: “Anna”,
“scripts”: {
“start”: “node server.js”
“dependencies”: {
“express”: “^4.16.4”
“engines”: {
“node”: “8.x”
“repository”: {
“url”: “!/hello-express
“license”: “MIT”,
“keywords”: [

Same problem here. Took me a while…:sweat_smile:
SOLUTION: Paste the link to the actual app.

1 Like


I solved the problem by using the link given in
“Introduction to the Managing Packages with npm” Challenges at the very beginning of “Managing Packages with Npm”.
Look for " Start this project on Glitch using this link … to start a glitch project that is linked to freecodecamp.
As soon as I used this link, I was able to evaluate my tasks.

Hope, I can help you out with this hint.

1 Like

I had the same issue as many of you and the only solution that worked for me was when I did the following:

  1. In Glitch, upper-left drop-down, chose ‘New Project’
  2. At bottom of this window, chose ‘Clone from Git Repo’
  3. From GitHub ( clicked ‘Clone or download’ and clicked the copy button (clipboard icon)
  4. Pasted the link to the repo into the window on Glitch
  5. At this point I had an almost empty Glitch project, just a and an empty ‘assets’ folder. So I downloaded the GitHub repo as a ZIP so I could add what was missing.
  6. Extracted the contents of the ZIP.
  7. On Glitch, clicked ‘New File’ and then ‘Upload’ and uploaded the package.json from the extracted repo.
  8. Added the author key as requested
  9. Also had to upload the server.js file to get the tests to pass.

I’m not sure why the project didn’t work from Glitch to begin with or why it didn’t properly clone into Glitch, but this was how I got past this block.


Thank you for your answer! It’s working for me.
As I can see it wasn’t properly cloned because there are two branches and by default the master branch was clonned. And all code stores in gomix branch.

I solved it by uploading the project “” on cloud9. Then i was getting error “not found” when i was parsing the URL on freecodecamp. The freecodecamp page were looking for “projectUrl//api/package.json” instead of “projectUrl/api/package.json” so i corrected in the server.js and it worked

I had same problem: my solution: I copied and changed the full server.js file from here.
This resolved the problem…

After a while going through the comments below, I figure out how to fix this problem. You have to copy the actual URL of the app in Glitch. Like below:

  1. Click on the glasses icon in Glitch
  2. Copy your Glitch app URL from the browser URL bar
  3. Paste it in freecodecamp
  4. Happy coding! :smiley:
    Hope it help

one more option is here
if we go to “share” we need to choose Live App option.

it worked for me thanks :+1:

I found the solution by doing these steps:

  1. clone this repository to your github account
  2. change the project.json file (add author) and then commit the change
  3. open glitch, create new project and choose import from github and then put your repository URL

thank you so much for sharing this solution!