I am not able to claim my Certificate

I am not able to claim my Certificate
0.0 0

#1

I have Competed all the challenges in “javaScript Algorithms and Data Structures Projects” section of the Javascript Algorithms And Data Structures Certification but still I am not able to claim my certificate.

And on My welcome Page it still says – "You have built 4 out of 30 projects."

Although as you can see in the below screenshot all the projects of “javaScript Algorithms and Data Structures Projects” are shown as completed

@QuincyLarson


#2

I was wondering about the same problem.
have you been able to fix it?


#3

nope, I am still waiting for some response.


#4

@pawansingh972 @stel This is a known bug that is being worked on.


#5

ok thanks for letting us know will wait for the fix.


#6

I have the same problem (I’m complete on the JavaScript projects but can’t claim) but I may have additional data. If I understand correctly, you claim certificates by going to your Settings page, and you have to have affirmed the Academic Honesty policy. Having done so, the claim form(s) should show up. (This is my understanding from reading the forum here, as I have not personally seen these forms).

However, when I click the Academic Honesty section’s Agree button, nothing happens. The button stays green and nothing happens to the page.

BTW, I have the “4 of 30 projects complete” notice also. My actual count is three website projects and the 5 javascript projects/challenges.

I’m running MacOS Sierra (10.12.6) and tried the Chrome and Safari browsers.


#7

@pawansingh972 @dcc1079
I have seen someone claim the certificate. Has it worked for you guys?


#8

@stel
still not working for me.


#9

@pawansingh972 have accepted the honours code in the settings?


#10

@stel

It’s not working for me. Clicking the Academic Honesty “Agree” button still does nothing. Refreshing the Settings page gets the Console errors that have already been detailed in one of the related GitHub issues:

https://github.com/freeCodeCamp/freeCodeCamp/issues/17426 has not changed (last update 4 days ago).

https://github.com/freeCodeCamp/freeCodeCamp/issues/17278 has not changed (last update 2 days ago).


#11

Same for me, anyone found a fix yet?


#12

Also, I’ve noticed that if I go back to a project, all my code is gone.
Having the problems with the “Agree” button and claiming the certification too.

I hope I won’t have to write the “Cash Register” and the “Roman Numeral Converter” challenge again :confused:


#13

According to this Github topic

Just to re-iterate the workaround:

You may need to do a hard-refresh, (Ctrl + F5 or Cmd + Shift + R) to get the latest changes, because the CDN would cache the old code for a while.

For the fix to work properly you should have to complete any challenge on learn first, that will automatically migrate some things to get you around this issue.

I found I had to resubmit all the JS challenges to resolve. But only on an id that had completed the challenges before the update on the day of the update(on 30th May), once I resubmitted them all it was fine.
~ @johnkennedy9147

The challenges that you would need to submit are

Palindrome Checker
Roman Numeral Converter
Caesars Cipher
Telephone Number Validator
Cash Register

Worked for me, the certifications part re-appeared but I cannot claim the api and microservices certification


Completed all projects in Javascript Algorithms and Data Structures but some show as incomplete in Settings Panel
#14

Has anyone found any way out??


#15

+1 Any solution on the horizon?