I can log into freecodecamp.org but it logs me out at learn.freecodecamp.org

I can log into freecodecamp.org but it logs me out at learn.freecodecamp.org
0.0 0

#1

I used to log into freecodecamp.org with my Github account so I clicked the link that said “If you previously signed in using Google, Facebook, GitHub, Twitter, or LinkedIn, click here to add an email address to your account and sign in.” and I was able to log in. It appears that my progress has been saved. But when I go to click on “learn” at the top it looks like I am logged out. I also don’t see where I am supposed to add my email in the settings.


#2

Having the sames issues here to !


#3

I think that once you’ve logged in, it just looks like you are logged out on learn.freecodecamp.org because the “login” button is there. If you actually go to one of the challenges though, you’ll see “settings” in that spot instead. Obviously this is still a bug, but it isn’t one that prevents working on challenges. I don’t think that there is currently a way to change your email address from your settings.


#4

This is what I see when I log in.

After I click on “Go to my next coding challenge” it takes me to the very beginning. My dark theme is gone. I even completed the challenge but it’s not saved to my timeline.


#5

I’m having the same Issue. Not only that but it seems like all my progress has been completely wiped as well.

Please Help!!!


#6

Try refreshing learn.freecodecamp.org - your progress is definitely there. You should be signing in with your info@***** account. Let me know if that works :slight_smile:


#7

The specific challenge “Say Hello to HTML Elements” appears not to be getting marked as completed.

I have also noticed that the dark theme hasn’t been applied to challenges. For now I’m just being patient because it’s a small, cosmetic issue.


#8

The dark theme doesn’t work on Learn yet - we’re working on it.

I’m not sure why you aren’t automatically logged in on Learn - try refreshing, and if that doesn’t work, click the “login” button real quick and you should be able to log in and it should work.


#9

Send an email to team@freeCodeCamp.org with any information you have about your account (GitHub username, etc) and I’ll help you fix it :slight_smile:


#10

@QuincyLarson what worked for me is after it did not sign me in using the other account link I just typed in my email into the sign in field entered my email attached to my github account, entered the 6 digit sign in code and then it signed me in with all my past progress. There must be a bug following the link which puts users in a loop of not being able to see their progress or look like they have signed in


#11

i am also having the same issue


#12

yes its kinda a loop and very annoying one because i logged in now 4 times couldn’t get my progress and keeps asking me to login on learn.freecodecamp.org


#13

@iamzakofficial be patient my friend. This is a free service. Please give the developers some time to work on this issue. You should understand how frustrating it is to fix bugs. Don’t you?


#14

@hackedWifi yes bro i do but i have idea when this update came i am coming back to FCC after 2 months so i thought this is only happening to me but now i know its happening to many campers so assume this update came very recently


#15

Yes, it came today or yesterday. I worked on FCC like two day ago and this was not like this.


#16

hmm alright, lets wait and let them solve this issue.


#17

Thanks for your understanding and patience. Given the huge scope of the update that happened today, it’s gone surprisingly well. There will always be bugs and glitches with a major push to production though, so it’s good that FCC has such a supportive community and amazing contributing team.


#18

Thank you Quincy! After I signed in with my email my profile picture shows up when I go to learn.freecodecamp.org.


#19

Hi Ariel,
I noticed that the “Say Hello to HTML Elements” is not being marked as completed and my dark theme is not applied as well. The theme is not a big deal but I would like to keep it if possible. Thank you for all your help and I will be patient while the bugs are being fixed :slight_smile:


#20

Yeah, it says that I’ve completed 320 challenges and 12 projects, but when I go to the curriculum, it lists everything as uncompleted. There seems to be some disconnect there…