I think I encountered a bug and now can't finish the exercise

Hello everyone.

This evening i was having a try in the exercise “Learn basic CSS by Building a Cafe Menu” and stumbled upon the task 87, whitch I found confusing. I tried various ways of completing the exersize till I finally got it correct, but it wasn’t what the task asked for so I took a screenshot of the task and wanted to share it with you guys.
Next I was trying to find the forum page, which I acidentaly found while trying to complete the task, so my mind went “why not just restart the task I already made?”, so I did it. Then I acidentally pressed on FreeCodeCamp link to main page and when I wanted to go back to the task, there was only code and preview displade, no buttons, no task description. And I tried fixing it by refreshing the page, completing the previos task and hoping it would work, but it left me with the same screen in front of my eyes.

Please help.

I’m having the same issue on step 14. I literally just made a post right before you lol.

Hopefully someone knows the answer

1 Like

Edited: OK, I think I see what you are saying now. I think you are running into this bug. I don’t think there is a solution at this time other than skipping the step. You could try a different browser to see if that helps.

I don’t understand what you are saying here. How can you get it correct if it wasn’t what the step was asking for? Did you actually get the congratulations message after clicking the Check Your Code button?

1 Like

I still have the screenshot that I couldn’t put in before since new members can post only one picture in the post. Here it is:

According to that screenshot you got the right answer. So I’m not sure why you said it wasn’t what the task asked for?

Because it asked to apply address class to p element which contains the address, and not the one containing “123 Free Code Camp Drive”. I found it confusing so I thought other students might find it so too.

I think the editor region missing is a known bug, but it is hard to reproduce. I assume if you hard refresh the page, it should get back to normal.

Hard refresh: Hold down the Shift key and left-click the Reload button (should work the same for all browsers and OSs I think)


Address as in a street name, not the URL address.

Edit: I agree, it can be misinterpreted and should probably be clarified.

1 Like

Ahh, I see. The p element containing "123 Free Code Camp Drive” is the address the instructions are referring to. But perhaps that is not quite clear enough and the instructions need to be clarified a little.

1 Like

Thank you, I’ll try.

Opened issue #49595 to clarify instructions.

1 Like