Install and Require Helmet (getting it wrong)

Tell us what’s happening:

Your project link(s)

{
“name”: “fcc-infosec-challenges”,
“version”: “0.0.1”,
“description”: “fcc backend boilerplate”,
“main”: “server.js”,
“scripts”: {
“start”: “node myApp.js”
},
“dependencies”: {
“express”: “^4.14.0”
"helmet": "^3.21.3"
},
“keywords”: [
“node”,
“hyperdev”,
“express”,
“freecodecamp”
],
“license”: “MIT”
}



solution: https://replit.com/@HenryChang7/boilerplate-infosec-11

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/89.0.4389.114 Safari/537.36.

Challenge: Install and Require Helmet

Link to the challenge:

Hello there,

Can you see the syntax highlighting in the package.json? It is showing a syntax error in your code. Also, the error in the Replit console is warning there is an error.

The tests cannot run, unless the Replit app is running, and the Replit app will not run, until the syntax is corrected.

Hope this helps

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.