Instructions for using git-it-electron on windows, for first project in back end

if you’re like me, you probably looked at the instructions requiring you to go to cloud 9 and hit the credit card part for registration, then paused. Even though it is totally free. Being confronted with a credit card request is just enough to give someone pause, even when they are offering a cool, free service that would let you do these projects over your android tablet, for example.

Then looking at the instructions, I notice it says we’re using git-it and when I go to their page, they say “this is the CLI version, and there is a newer, spiffier gui version which is the primary version now”. That’s not an actual quote, I’m paraphrasing. This is still a tutorial for using the git commandline tool, do I really need a gui version? Well, if you saw that “primary version” thing I paraphrased up above, you know the answer to that question in your heart already…

I already have installed npm and git on my system. So I can do this right nere, no Cloud9 needed.

So I opened the PowerShell, used the same command I saw, but for git-it-electron npm i -g git-it-electron and then tried git-it … and got nothing. git-it-electron? still, nothing. The git-it-electron github page’s readme… has no instructions for getting the executable up and running.

In cases like this, the next thing to do is npm uninstall -g git-it-electron. Good, now I can figure out why this thing isn’t building. Here’s the steps I took to get it running:

  1. make a project directory within your favorite place on your drive for github projects … like mine at C:\github
  2. cd in and run npm init -y to get a skeleton package up.
  3. npm i -s git-it-electron
  4. there’s no executable in node_modules/.bin … so, cd ./node_modules/git-it-electron
  5. read that package.json. The scripts you need to run are:
    a. npm run build-all
    b. npm run pack-win - but this one won’t work yet.
  6. now you’ll need to build an electron app: npm i -g electron-packager
  7. ok, so you can run 5.b. now :slight_smile:
  8. you’ll notice a brand new Git-it-win32-ia32 directory … this means I probably should have given it a flag for 64bit, but oh well. In that directory is a file Git-it.exe. Run that.

Have you tried through here? It’s just a git tutorial after all, this should take you through the same steps as git-it-electron, except directly.

Either way, your problem is that you don’t have git-it. They don’t have a npm package yet i think, just go here: for their releases, download the most recent package and install as any other software.

After that, git-it-electron should work.


I don’t know if you read what I wrote very closely … I am not having any problems. But thanks for trying to be helpful!

@robbiemu is another good place to complete the backend projects as an alternative to cloud9.