Learn HTML by Building a Cat Photo App - Step 15

Currently on Step 15 and I’m pretty sure this is the correct way to code it. However, It keeps saying " You should only add one opening anchor (a ) tag. Please remove any extras".
Removing any opening anchors either removes the image or no longer allows me to make a link for it. Need Help!!

Your code so far

<html>
  <body>
    <main>
      <h1>CatPhotoApp</h1>
      <h2>Cat Photos</h2>
      <!-- TODO: Add link to cat photos -->
      <p>Click here to view more <a target="_blank" href="https://freecatphotoapp.com">cat photos</a>.</p>
     <a href="https://freecatphotoapp.com"><img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/relaxing-cat.jpg" alt="A cute orange cat lying on its back.">
    </main>
  </body>
</html>

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/106.0.0.0 Safari/537.36 Edg/106.0.1370.47

Challenge: Learn HTML by Building a Cat Photo App - Step 15

Link to the challenge:

Hi! The error message is a bit misleading.

Let’s compare the anchor tag you did previously with this second one.

<a target="_blank" href="https://freecatphotoapp.com">cat photos</a>

There is a closing tag missing from the anchor tag.

<a href="https://freecatphotoapp.com"><img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/relaxing-cat.jpg" alt="A cute orange cat lying on its back.">

Hello!

Applied a closing tag to the end but still getting the same error.

<a target="_blank" href="https://freecatphotoapp.com"><img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/relaxing-cat.jpg" alt="A cute orange cat lying on its back."</a>

You accidentally removed the > at the end of the img element