Learn SQL by Building a Student Database: Part 1 - Build a Student Database: Part 1

Tell us what’s happening:
Hi everyone, I have this problem before this moment the same problem was resolved cancelled the path on the CODEALLY dashboard, but this time nothing, I also tried with the connections and browsers.


Your code so far
=> become → and don’t work.

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36

Challenge: Learn SQL by Building a Student Database: Part 1 - Build a Student Database: Part 1

Link to the challenge:

The same error appears when I use SELECT * FROM

thank you for who can help me!

When the postgres cursor changes to ->, it is because the previous command has not been terminated yet (with ;). You can create multiline commands by hitting Enter and continuing on the next line. To terminate and execute a command, you finish with a semicolon.

So, if you’re stuck with that cursor, just enter a semicolon and you should return to the => cursor and can begin a new command.

If you get stuck and all else fails, you can always close down the terminal and open up a new one.

Thank you a milion, this works!

If possible, I gave another related issue: very often cursor changes to (> and when I open a new terminal I have this:

Screenshot 2023-05-03 152642

Thank you again

There are sometimes stability issues, and I’ve had connections drop like this at times too.
Unless there’s a persistent outage issue, usually it reconnects almost immediately and I can continue from where I was but, if I ever get stuck in the terminal and can’t get going again, I just close it down and open a new one.

Thank you a million, I understand!