Learn SQL by Building a Student Database: Part 1 - Build a Student Database: Part 1

Tell us what’s happening:
Describe your issue in detail here.
I am stuck here and nothing is working. Reset, clearing files. etc. Nothing. I cannot proceed.

Your code so far

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36

Challenge: Learn SQL by Building a Student Database: Part 1 - Build a Student Database: Part 1

Link to the challenge:

I made a post in Discord, but no one is able to help. Can anyone here help?

That connection reset error has happened to me a few times but normally everything works fine after that, so I wouldn’t worry about that.

After the connection reset, did you try adding the column back in again?
If you’ve added the column and the CodeRoad container is still not recognising that you’ve completed the step successfully, then I would try Reset and Run on the container a couple of times.

If that doesn’t work, then I’d try a soft reset from the Project Options menu (top-left).

If you have tried all of these things, your table definitely has the correct column added and the CodeRoad container still won’t let you pass the step, then it could be related to the issues which cropped up recently where project containers were deleted/corrupted.

If all else fails, you may need to delete the project container at codeally.io and start this course afresh. As far as I know, all new project containers should be working ok.

I log in, type in the command…

Hit run to confirm the ERROR…

Hit Reset after Run

Enter command again…

Again, enter command…

Drop column…

Add column, again…

Did a soft reset, same issue…

I really, really don’t want to restart the entire course. You’re asking me to just burn 5-6hours. I think that’s a bit egregious, since there is no assurance this won’t happen again. You’re saying the containers are working ok, now, yet they clearly are not.

To be clear, are you suggesting I restart the course, therefore I lose all this?

No you wouldn’t lose anything other than your progress on the current course (i.e. Students Database Part 1).

That said, I can now see what you’re doing wrong.
You should be connected to the students database, before you try adding tables (or columns to tables).

I went to Project Options, then Soft Reset. Now its telling me Test Runner Failed when I hit Run. Hit Reset button, try again, same thing.

I can see with git history that I am typing it in correct.


Maybe you could help me, I think one of my files accidentally got deleted, so when I try connecting to students via “–dbname=students” (also I’m on building a student database part two) it responds with an error, “No such file or directory.” I can’t seem to figure out how to give this course a full reset from CodeAlly. I’ve spent a decent amout of time looking, but I can’t seem to find out where to do that. Any ideas? I already used the reset button and did a soft reset.

If you want to do a full deletion of any particular course in the Relational Databases certification, you go to codeally.io (login with GitHub), click on the Cloud IDE tab and then select and delete the relevant course from there. Then, when you go back to FCC, the course will start completely afresh.