World cup database still not working

blank screen. no menu. no coderoad. no nothing.

Had you already started this course before the recent outages happened? If so, did you save any of your work locally (e.g. an sql file)?

As far as I know, courses which were already in progress are not possible to continue at present. You have the option of waiting to see if this can be resolved or deleting the project container and starting again. If the latter, you should find that everything works fine once you’ve restarted. Also, if you have saved any of your work locally, you can rebuild your database and continue from there.

Thank you for responding. I started the course already. No, I did not save a local file. I can restart it’s not a problem.

How do you delete the project container? The screen looks blank.

You need to go to codeally.io and login, then click on the Cloud IDE tab.
You should see a list of your projects and you can delete any which you wish to restart.
Once deleted, go back to FCC, start the course and you should be back in business!

I tried that I got this screen. Is this how it’s supposed to go?

Yes, then click on the Cloud IDE on the left and you’ll see your projects. Click on the three dots to the right of the relevant project and delete it.
Then go back to FCC and restart the course.

1 Like

Thank you, now I can load it. I won’t have to do this again, right?

I think that the issues which occurred recently have now been resolved, so all newly-started courses should work fine.
However, I’m also working through these projects at the moment and I try to ensure I’ve saved my progress locally, in case of issues arising again.
So, for the World Cup course, I’d save a dump of the database into an sql file and then save that locally, along with the two shell files.

I reset it in codeally. I am able to get back into database. Thank you.

Error on connection

codeally@aeb5d5c78c69:~/project$ psql --username=freecodecamp --dbname=postgres
psql: error: connection to server on socket “/var/run/postgresql/.s.PGSQL.5432” failed: No such file or directory
Is the server running locally and accepting connections on that socket?

running Coderoad does not give me any checkmark. I refresh the browser. I ran the Coderoad a few times. nothing. Would someone please help?

Have you now completed this project but can’t get the checkmark? Is that what you mean?

I believe I have completed the project. I needed to know if everything passes.

The project loads up correctly and the CodeRoad container appears?
You can get to this point?


If so, what happens when you hit ‘Run’ on the tests? Does the test runner finish running and show any green checkmarks for tests which are passed?

Like you said the code container I appear. I was able to complete the insert_data.sh and the queries.sh. However, when I hit ‘Run’ (and I did it several times). It ran but no green checkmark anywhere.

Does your database exist? Have you recreated the tables and their relations with each other?

I just double checked to make sure everything is there. My database exists. I just reran (before I reply to your post to make sure) my queries.sh and it produced the expected result. I also ran the test again and no green checkmark.

After hitting the ‘Run’ button, does any error message flash up just above the button (like highlighted here) after the tests have run?

Yes, there was. It as too fast and it didn’t stay so I can’t capture it.
I reset it and everything is gone.

If you can make note of the error message then it should be possible to figure out what is wrong.