Learn SQL by Building a Student Database: Part 2 - "Your Script Should Have the Correct "Shebang"

Currently stuck on step “Add a shebang that uses bash at the top of your new script”. I am using the correct “shebang” #!/bin/bash and it will not pass. Did everything correct prior, currently in a split terminal with SQL on the left and BASH file on right connected to ~/project$. Tried different browser, reset code, and even cleared CODEALLY project info and started over, same issue. Any help would be much appreciated.

1 Like

please post a link to the project website for our convenience and post a screenshot of your screen when the issue is happening.

My post has been updated with screenshot and link added, thank you.

Also, please ignore the left side of the terminal where I tried to enter the “shebang” I know it doesn’t go on the SQL side, was just trying everything.

You are trying to write the declaration in the terminal but it needs to be in your shell script file. Double click the script name on the left to open it. Then write the declaration there.

Wow, yeah I knew that too…time for a little break lol. Thank you so much for your help!

1 Like

I have to add that you save the file afterward. Worked for me.