My first app in React and Electron - changes do not register

Hello,

I have started making an app in Electron with React. This is the first time I am doing it. I have followed this tutorial: Electron with React JS under 40 min! - YouTube to the point where the app starts with npm start and shows a header and a button (so ca 25-30 min in, later he adds some scripts that I think I don’t really need so I diverted from there).

The thing is, I have done it a few days ago and finished the day with pushing it all into git (after struggling with some big sized files and so adding a .gitignore). Still worked. But yesterday I came back to this project and wanted to develop further functionality when I noticed that my changes to the code are entirely ignored when I run npm start. Even the most basic thing like changing the text on the button or changing the text color do not show.
The server is stopped every time I quit the app and I know I start it anew with every npm start. It is gotten so ridiculous that I have deleted my App.js entirely (there wasn’t much to begin with, except the button and an h1), expecting to see many reference errors, because index.js imported that one. But nothing, still runs.
It feels like some problem with cache? Like it just runs some pre-saved state over and over again and does not even look for what is currently saved in the editor.
I am completely lost as to how to proceed. All suggestions will be helpful.

  • Anna
1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.