New contributor localhost:3000 not working

Hello,

I am on a Mac and have installed the repo locally. I am having trouble with ‘npm run develop’

I am able to see the homepage at localhost:8000, but I cannot go to localhost:3000 to sign in or to the localhost:3000/explore page.

Any help would be appreciated.

If you followed the contributing documentation on how to setup the repo locally, then you just need to click the Sign In button when viewing the site on localhost:8000.

What documentation refers to this as a valid route? What are you trying to access?


In the steps, it mentions losing the app at local host:8000 and clicking the sign in button.

This sign in button leads to localhost:3000 which ends with an error.
I hope that helps.

Should it be
localhost:3000/explorer ?

Yes, I tried both; I wasn’t able to sign in at all.

When I try to sign in it just goes to an error that could not connect to localhost:3000

What is the error you see?


I attached an image of the error I see. Like before, I can connect to port 8000, but clicking the sign in button breaks due to a connection error on port 3000.

The fCC guide says to check if port 3000 is in use

netstat -a | grep "3000"

tcp4    0   0    0.0.0.0:3000           DESKTOP      LISTEN

% netstat -a | grep “3000”

tcp4 0 0 0.0.0.0:3000 DESKTOP LISTEN

zsh: command not found: tcp4

That was the result of that. I did have an error with mongod and it wouldn’t work, but running it as a MacOS service worked ‘brew services start mongoldb-community’, but I’m not sure if that is the same or behaves the same.

I wonder what this program is. Can you guess?

That is from this command
netstat -a | grep “3000”

tcp4 0 0 0.0.0.0:3000 DESKTOP LISTEN

from the fcc guide.

I am going to manually install mongodb, as it has an error and may be trying to install as an intel based form instead of arm for Mac m1.

Oh right (didn’t notice the output was so long).

Have you double checked your node.js and non installs too?

node -v
npm -v