Please need help! Possible bug in site


I am a new memeber. MY name is Avinash. I am encountering some problems using site to learn. I will try to describe the situation as clearly as I can. English is not my first language so please bear with me.
I was at the “add placeholder to a textfield” lesson and I suddenly couldn’t bring the cursor on to the last line to edit the input tag and add the placeholder text. I tried clicking there but that didn’t work. Then I clicked in the middle of the text editor and the cursor appeared there. Then I tried to bring the cursor down to the last line by using the arrow keys on my keyboard. But it would move only up to the first character on the last line. I kept on pressing the right arrow but the cursor wouldn’t move to the end of the string that was there when the lesson started. Then I closed my browser thinking I would start that lesson again. When I opened the browser and went to the site all my previous progress had disappeared. The tick marks on the lessons in the map windows was gone and all the lessons completed shown in my profile had disappeared. Please somebody help me with this. Should I log out before closing the browser? Is that why my progress wasn’t saved? Also help me with the first bug.
Browser: Mozilla firefox 54.0.1 (32bit)
OS: Windows 10 pro
Sorry about the long winded post.


Your progress is saved in two places:

  1. As you work on challenges they’re dynamically cached in your web browser’s local storage. If for some reason it’s cleared … well we get to place two.
  2. When you submit a challenge it’s stored on freeCodeCamp’s servers so you’d simply access it from the map and your progress will be accessible to you again.

Now as for not being able to use your cursor that sounds like a hardware/software issue. Are you having cursor issues on just that specific challenge or all challenges?

This sounds like a few issues have occurred, because of the comments about lost progress. Have you checked your progress directly at that should be able to fix any local storage issues. If the progress is still lost according to that page I recommend emailing and the issue can get fixed from there.

  1. I opened the map using the link you gave .But the progress is not saved there. There were no check marks to the left of the lessons.

  2. The cursor issue happened only once. I don’t think it’s a hardware issue because it doesn’t happen with any other softwares or editors.

I guess I will try emailing the team. Thanks for helping me @nsuchy


In this case the freeCodeCamp Team is the best place to reach out, if it’s an account related issue they’re the people who are most able to help :slight_smile:


hello, i’m sorry to reply to your post instead of opening a new one, but i think i had the same problem/bug.

Freecodecamp also crashed, and i simply left it, and came back later.
After i came back i realise the the counter had reset, but since i was starting with bootstrap (2nd chapter) i tought it was normal.
But now, looking at my profile i see that all my previous progress was lost. (
I should have progress on 15/07 and 18/07 too.


Just want to add that I, too, am experiencing the issue of not being able to place my cursor in the necessary place. Not only am I unable to click to place the cursor, but am also unable to get to the right spot with the arrow keys. The editor simply won’t let me place the cursor where I need it.

How, then, am I able to finish the challenges? Well, if I use random clicks mixed with random arrow keys, I eventually gain access to the spot I need to add text. I can’t tell you exactly what click/arrow combination works, but I can confirm that there seems to be an issue with the editor. Sounds like the same issue described here.

I’m using Chrome v61. If it would be best to contact/work with someone in particular on this issue, please let me know; I’ll help further if I can.