Problem passing periodic table database project

Hello ,
I have a problem passing the project periodic table database although I finished all the test cases and passed them , but the check mark of the project in the page of the certification is still unchecked and therefore I can’t submit the project repository link and pass the project
it tells me “you must complete the project first” however I completed it
what is the problem here

please make sure you have followed all the instructions including:

Important: After you pass all the project tests, save a dump of your database into a periodic_table.sql file, as well as your element.sh file, so you can complete step 2. There will be instructions on how to do that within the virtual machine.

and

Step 2: Submit your code

When you have completed the project, save all the required files into a public repository and submit the URL to it below.

Required files: periodic_table.sql, element.sh

I made a dump of the database but when I return and rebuild it again , I find that the progress stops at a certain point and some of the work isn’t saved like inserting the 2 new elements Ne and F and renaming the column ‘weight’ and other things related to the database

check your sql file. if the steps are in it, then you can try again to restore. But if not, I am not sure what would explain the missing steps.

can I drop the database and use the sql file to rebuild it ??
I can’t drop it as it said only the owners can drop the database

can you put your file in github and share a link? i am pretty sure that you can use it to redo all the database steps but maybe better read it first.

this is the link to the repository

it looks like the early steps take care of dropping the periodic_table db and recreating it.

since you already have your repo though, why are you trying to recreate it instead of submitting a link to the repo?

when I try to submit it , it says "you must complete the project first " although I passed all the user stories

can you tell me what URL you used?

https://github.com/AbanoubEdward97/build-a-periodic-table-database.git


the project should be marked completed here but it didn’t

drop database code was the problem in the sql file , thank you solevd .

1 Like

hi Abanoub, can you clarify what you did to fix it? (just in case someone else has this issue in the future?) Or can you clarify what was wrong in the .SQL file?

1 Like

I tried to drop the database and then made a dumb of my commands , the drop code was saved in the dumb file , when I tried to rebuild it again , i think it resets the progress every time I build the database , always read the commands in the sql file to know what is going on

1 Like

Hi, I think I have the same problem with this project. All the test checks pass, but the feature for linking my git repository does not unlock.

I checked my .sql file and there is a “DROP DATABASE” at the beginning, but when I comment it out, creating the database in a new instance of the project VM results in errors.

in the OP’s case I think he had a drop db at the end of his sql file. (so it was causing problems).

Please open a new topic for yourself to get help for your own unique case.