Product Landing page links

I can’t click the #submit element, when the email is submitted to a static page (use this mock URL: https://www.freecodecamp.com/email-submit) that confirms the email address was entered and that it posted successfully. I tried to use the action method and the (a href) method but both didn’t work.

Can you show us the code you tried?

I am sorry for some reason when I copy the code and past it to “Reply” on here nothing shows at all. Can you tell me how to share it?

Pasting code can sometimes cause problems. Remember this:

When you enter a code block into a forum post, please precede it with a separate line of three backticks and follow it with a separate line of three backticks to make it easier to read.

See this post to find the backtick on your keyboard. The “preformatted text” tool in the editor (</>) will also add backticks around text.

Note: Backticks are not single quotes.

markdown_Forums

thank you so much for the help

<form id="form" action="https://www.freecodecamp.com/email-submit">
                <div class="main-container">
                    <h4 class="subscribe-title text-center">You can Subscribe to our newsletter to be notified with the new products.</h4>
                    <input id="email" type="email" placeholder="Enter your email" required>
                    <input id="submit" class="btn btn-block btn-primary" type="submit" action="https://www.freecodecamp.com/email-submit">
</form>

that is part of my code that shoes the header of the form and the button tag

I don’t use HTML much these days. There are a few ways to do this. I think action is for forms. Have you tried:

onclick="window.location='https://www.freecodecamp.com/email-submit';"

I tried it but still doesn’t work

I think I’d need to see all your code. Do you have a pen?

Yes, And this is the link https://codepen.io/youssefhigazy/

The last pen.

I keep getting “**www.freecodecamp.org** refused to connect.” To me that sounds sounds like there is a problem with the web site.

I just tried two other people’s landing page projects and got the same error. I think there is a problem with the server at that site. I’d try again tomorrow.

Thank you very much for being careful. I highly appreciate it.

@youssefhigazy, @kevinSmith, this has been an issue for a long time. Over a year that I’m aware of. Go ahead and use the link to pass the test but ignore the ensuing error.

1 Like

I submit it as it is and i worked. Thank you very much for help!

@kevinSmith @Roma