Progress Not Saving Again

Hi there - I’ve passed all the projects under “APIs and Microservices Certification”, but the server is not saving my “Exercise Tracker” submission. Each time I hit submit, I receive a popup noting that I’ve completed the section:

then:

but then when I go to my Settings it shows that I haven’t submitted my solution:

and when I go back to the Curriculum it once again shows that I haven’t submitted the solution:

.

This happened with the other projects in that section too (e.g. timestamp, request header, file metadata) but I bypassed that problem but copying my link directly in “Settings” under “Legacy Back End” but there isn’t a field available for the Exercise Tracker:

Can I get some help please resolving this issue? I’ve tried on Safari and Chrome. Thank you!

That’s strange can you resubmit it and check again.

Hello there,

I have been unable to reproduce any issue. Would you mind resubmitting again, this time with your browser devtools open, and look for any errors as you push the Submit and go to next challenge button.

Hi there - please find below (these load as soon as I load the page, and loads further when I hit submit on the exercise tracker). I believe it might have to do with the fact that I changed my Github username recently but I can’t find the place where I can update my profile to link to the updated Github username (same profile, just new username). Should I revert to my old Github username?

Screen Shot 2021-05-11 at 2.50.00 PM

The GitHub username shouldn’t matter - but the email address does. Did you update your email address by chance?

Nope - I didn’t update the username - I downloaded my “data” from FCC and double checked my JSON data too and it’s the same email address.

Right, but did your GitHub email change?

1 Like

Nope - same email address. Only thing that changed was my github username.

Thank you, for sharing that. By your description, I would assume the next port of debugging would be finding out if anything on your end is blocking requests to https://api.freecodecamp.org/

The fact that multiple errors are showing up either means you are preserving your log, OR the client is still trying to send old requests.

PS As far as I am aware, you can ignore the last two errors, because I have always had those.


Are you able to try on a different network? Or, at least flush your DNS cache?

I flushed the DNS cache to no avail, and tried Firefox too and it didn’t work (in fact, Firefox couldn’t check the solution on Glitch at all because of CORS). However, I downloaded my solution to Replit and used Replit instead of Glitch and it worked…so while I have yet to stop the 403 from loading (it still continues to load when I launch FCC’s website), I have successfully submitted my solution. I guess I found the solution to my original question? Thanks for your help!!

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.