Relational Database Course SQL Reference Object Reset Issue

Hi there, so I started the last courses of the Relational Databases track a few days ago and have run into an issue since resetting. I only got around 20% of the way through before stopping for a few days and decided to reset the course to make sure I hadn’t forgotten anything. Now, the first step of the tutorial says to add a new folder called sql_reference to the project folder, which I was able to do. However, the first issue is that the tutorial didn’t seem to automatically track my progress like the other tutorials would. This was fine because after I hit run and the tutorial recognized that I had added the directory. After getting past this first step, the tutorial continues to give me a message after each time I input to the terminal directing me to use the mkdir command to add the sql_reference folder to the project folder. So now the tutorial will not recognize that I have completed each step until I enter “mkdir sql_reference” into the terminal, and on top of this the tutorial will also mark each step as complete given I enter that mkdir command even if I have not completed the other parts of said step. So, I have tried resetting the tutorial a few more times by making sure that the directory is deleted, terminal cleared and exited, cookies for freecodecamp reset, and even tried switching to Firefox all to no avail. Does anyone know what else I may try to fix this?

You may have to delete this container. Login to and find the vm playground. Then delete this course container after which you can restart from scratch from the fCC site.

Also one piece of advice, try to go easy on the reset button. Not saying you can’t use it but don’t use it often if you can and give it ample time to finish the reset.

1 Like

That worked, thank you very much! I will also keep in mind about not resetting the tutorials too often. Just out of curiosity, what happens when the tutorial is reset multiple times like you’re describing?

I have a theory that some people have run into unrecoverable errors because they have used the reset too much. (Or perhaps have not given it enough time to work, I haven’t figured out exactly which)

The symptom of a serious errors looks like a message “Test Runner Failed”. And sometimes I can help them but many times I can’t. I hope you can avoid it.

1 Like

That’s interesting, thank you for letting me know and again for the solution!

1 Like

where is vm playground?? i want to reset my course