"Solution Link" not working?

solution: GitHub - TRONgui/boilerplate-npm: A boilerplate for the freeCodeCamp curriculum.

These link are not being validated. Not sure if I have to pay Replit so I can “Publish”?
I’m a tad confused. Tried all day both using GitHub, Replit, stackblitz.
Any help appreciated.

Safari 14.1.2

Challenge: How to Use package.json, the Core of Any Node.js Project or npm Package

Link to the challenge:

you submit the url that appear above the live preview,, make sure the app is running when you submit

Oh! Above the live preview. That wasn’t mentioned anywhere and I hadn’t even noticed, also didn’t know “it should be running”, I clicked the Run button this time but I still get the usual error:

// running tests
package.json should have a valid “author” key (Test timed out)
// tests completed

I looked at your code before but didn’t see the author key, have you added it?

1 Like

I’m an idiot! lol
In this last attempt I actually forgot to do the assignment, yes.

Then the preview area and live url disappeared, had to click around back and forth to get it back. Not sure what I did, but I got it working.

Something easy like this would have helped me a lot and saves support from repetition:
• Sign up on
• Click the Replit link in the FreeCodeCamp exercise
• On Replit click the .replit file and hit “RUN” and wait for it to start up
• Check for error messages
• Copy live link above Preview area on Replit
(and then explain how to get the preview and live url to display. I reloaded the page and now it’s gone again. Let’s see if I can get it back again.)

…or something like that. Just the basic instructions. At least I would have had something to struggle with :slight_smile:
I was totally lost.

Thanks for your help.
FreeCodeCamp rules!

Yeah I’m stuck now. Tried navigating around the page like I did last and then go back to the same repl but I can’t get the preview to display no more. Also can’t find anything on “preview” or “preview gone” in their forum.

Does anyone know what I’m missing?

I’ve tried closing the preview, and it reopens once I press Run again, I have no idea what to tell you

Ok, thanks.
It must be these error messages, but I’m pretty sure they were there during every step of the exercises. Maybe I’m wrong.

throw err;

Error: ENOENT: no such file or directory, open ‘/home/runner/boilerplate-npm-5/index.js’
at Object.openSync (fs.js:462:3)
at Object.readFileSync (fs.js:364:35)
at Object. (/run_dir/interp.js:195:19)
at Module._compile (internal/modules/cjs/loader.js:999:30)
at Object.Module._extensions…js (internal/modules/cjs/loader.js:1027:10)
at Module.load (internal/modules/cjs/loader.js:863:32)
at Function.Module._load (internal/modules/cjs/loader.js:708:14)
at Function.executeUserEntryPoint [as runMain] (internal/modules/run_main.js:60:12)
at internal/main/run_main_module.js:17:47 {
errno: -2,
syscall: ‘open’,
code: ‘ENOENT’,
path: ‘/home/runner/boilerplate-npm-5/index.js’

I’ll try the replit support with this issue.

@guiGOD It is an common issue. It always happens. You need to load up, means open the .replit file before running.

1 Like

Thanks for coming to my rescue! So annoying when you’re eager to do these exercises and then being held back by a technical issue.

It works now!

So now I learned how to Run the project, but now it says “Not found” in the view port, and FCC is not accepting my links.

Also the 3 lessons I did in “Basic Node and Express” so far has been wiped. doesn’t really matter in this case but it’s a problem across the site that lessons already completed are wiped.

that’s normal until the appropriate challenge

what link are you submitting?


Here’s my link

I get this error on FCC

// running tests
"Hello World" should be in the console
// tests completed

Does error sentence has (Test Timeout) at the end?
If it is, it means you need to click the I've completed this challenge button again.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.