"Run the Tests" Button not working

"Run the Tests" Button not working
0.0 0

#1

Whenever I finish certain lessons, clicking on the “Run the Tests” button doesn’t change anything in the console. It still says that my “output will go here.” This randomly happens and I find that leaving and coming back every now and then causes it to work. It has caused me to sit and correct code that I had had correct from the start for hours. Is there any way to fix this issue? Refreshing the page has only worked once for me.


#2

Are you by any chance using Edge, IE, or Safari as your browser? Free Code Camp has bee updated to use newer technologies. It makes the application much faster and it means that we can go much longer without having to do a huge migration like the recent one. However, Edge, Internet Explorer, and Safari are very bad about choosing not to adhere to standards and support new functionality in JS and CSS. Right now, that means that these browsers exhibit lots of unexpected behavior. If you become a web developer you will come to hate these browsers with every fiber of your being.


#3

I was facing the exact same issue and I’m using Chrome. I tried refreshing the page a lot of times but the button was still unresponsive every time I hit ‘Run Tests’.

Then I opened the developer tools and I saw there was an exception generated because of the 'use strict’ tag clashing with the default parameters. Removing it allowed my tests to run once again.

I’ve attached images below in case someone at support wants to reproduce the error.
Image 1 - Run Tests Not Responding
Image 2 - Exception in Developer Tools


#4

Hello,
I have exactly the same issue, and have tried on multiple browsers, ranging from Firefox to Opera

If someone could help out, would be great :slight_smile: