"Run the Tests" button not working on some challenges

"Run the Tests" button not working on some challenges
0

#1

Hey, I have run into some problems with a few challenges where i’m unable to run the test. There is no feed back given in the “your test output will go here” area when i click run the test. Its only happened to a few of the challenges , and I just skip it when this does happens, but I will eventually have to go back and complete it, so i’m wondering if anyone else has had this problem and has figured out the solution! Thanks


#2

Every once in a while, in the process or writing the correct code a syntax error will be created when the live example panel updates. This error can cause the tests to hang. If this happens to you, just copy your solution, reset the challenge, and paste your solution back in.


#3

I’ve tried that. I’ve also looked online for the solutions to the challenges to make sure its not a problem with the code, still nothing :confused:


#4

Are you by any chance using Edge, IE, or Safari as your browser? Free Code Camp has bee updated to use newer technologies. It makes the application much faster and it means that we can go much longer without having to do a huge migration like the recent one. However, Edge, Internet Explorer, and Safari are very bad about choosing not to adhere to standards and support new functionality in JS and CSS. Right now, that means that these browsers exhibit lots of unexpected behavior. If you become a web developer you will come to hate these browsers with every fiber of your being.


#5

I am having the same issue. “Run Test” button is not working, getting stuck at “// running test,” nothing happens. Tried resetting and reentering code several times, never moves any further.


#6

Bugs should always be reported as GitHub Issues. Whenever reporting a bug, please check first that there isn’t already an issue for it and provide as much detail as possible.