Setting up FCC on Windows

Hey guys. I was trying to set up the local environment for FCC. Seeing the installation guides though I see that I can’t install Docker because I’m on Windows 10 Home. I tried Docker Toolbox but that is now legacy and they only offer Kitematic. Kitematic won’t install even though I have the requirements (VirtualBox, Docker Machine (It’s stuck on that now)). So…

Is there another way? Thanks.

1 Like

The old directions that predate the docker workflow should still work:

Thanks I will check it out.

I am getting this error at npm run seed

    throw err;

Error: Cannot find module '../rev-manifest'
    at Function.Module._resolveFilename (internal/modules/cjs/loader.js:603:15)
    at Function.Module._load (internal/modules/cjs/loader.js:529:25)
    at Module.require (internal/modules/cjs/loader.js:657:17)
    at require (internal/modules/cjs/helpers.js:22:18)
    at Object.<anonymous> (C:/Users/slenssen/Documents/GitHub/freeCodeCamp/server/middlewares/jade-helpers.js:2:1)
    at Module._compile (internal/modules/cjs/loader.js:721:30)
    at loader (C:\Users\slenssen\Documents\GitHub\freeCodeCamp\node_modules\babel-register\lib\node.js:144:5)
    at Object.require.extensions.(anonymous function) [as .js] (C:\Users\slenssen\Documents\GitHub\freeCodeCamp\node_modules\babel-register\lib\node.js:154:7)
    at Module.load (internal/modules/cjs/loader.js:620:32)
    at tryModuleLoad (internal/modules/cjs/loader.js:560:12)
    at Function.Module._load (internal/modules/cjs/loader.js:552:3)
    at Module.require (internal/modules/cjs/loader.js:657:17)
    at require (internal/modules/cjs/helpers.js:22:18)
    at requireNodeOrEsModule (C:\Users\slenssen\Documents\GitHub\freeCodeCamp\node_modules\loopback-boot\lib\require.js:7:17)
    at C:\Users\slenssen\Documents\GitHub\freeCodeCamp\node_modules\loopback-boot\lib\executor.js:351:19
    at Array.forEach (<anonymous>)
npm ERR! errno 1
npm ERR! freecodecamp@0.1.0 seed: `node seed/index.js`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the freecodecamp@0.1.0 seed script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\slenssen\AppData\Roaming\npm-cache\_logs\2019-03-21T21_14_21_443Z-debug.log

@kirubiel Here are the new docs for docker setup of FCC.

No that ain’t gonna work for me. Docker doesn’t run on Windows 10 Home.

That’s why they made docker-toolbox for Windows 10 Home. Give it a try.

It’s deprecated. It’s replacement is Kitematic but even though I have completed the requirements it still won’t install.

Have you tried using WSL?

No I haven’t. What is that?