Setting up FREECODECAMP locally on windows machine

I am getting this error after NPM Install command. Please Help

Would you mind copy/pasting all the commands you used and the results, so we can see exactly what you tried (all steps). It is probably best if you try to start at beginning of the documentation again and work through each step.


NOTE: When you paste your command line text your reply, please precede it with a separate line of three backticks and follow it with a separate line of three backticks to make easier to read.

See this post to find the backtick on your keyboard. The “preformatted text” tool in the editor (</>) will also add backticks around text.

Note: Backticks are not single quotes.


I had this page after i click sign in or start coding at localhost:8000. Any solutions :O? took me whole day to figure all the way to get it working on local…

I have a general perception that I can use freecodecamp locally to access all tutorials and learning material…Please correct me if I am wrong. short of internet here…

I’m getting an error as well on install.

I do not have Docker installed so I was following the local setup instructions and got this error when doing npm run seed in step3 of the ‘how to setup freecodecamp locally’ instructions here

(removed image because new users can only upload one image per post)

something about not being able to find a module. Am I missing something here?

My setup:

  • Windows 10
  • Node 10.15.0
  • MongoDB version 4.0.6

Thanks! any help would be appreciated!


I managed to get it to seed. I’m not too sure what happened. But what I did was just a complete do over.

  • I just re-forked the main fcc repo
  • clone it down
  • Ran npm ci
  • Ran mongod
  • Ran npm run seed

But when trying to run npm run develop I got the following error with gatsby.

Hope to get some help here.


You can, but cloning and running it locally it is primarily for if you are contributing to the development of FCC itself, it isn’t just an app you can easily install and use. It means that if you’re building out parts of the UI or the curriculum or whatever, you can make sure it works (rather than being a method of working through FCC as a learner)

@pakatagoh Did you make sure to setup the environment variable file?

HI, thanks Dan, I understand. But I need it as a learning platform for offline as I have minimal access to Internet. It end up working for me, I just won’t be able to get hints or video turotial links but I guess I can deal with that. Access to Internet in Cuba is not easy =/

1 Like

Hi @RandellDawson, Thanks for the reply!

It’s working fine now. I’m not sure what went wrong with the setup but it definitely wasn’t the .env file. I made sure I made a copy from the sample.env file

Maybe it had something to do with having yarn on my system as well. Because after uninstalling it and restarting my computer, everything worked fine. Will update here again if there any other OS issues.

Thanks again for the response!

1 Like