Solana-curriculum

Followed the Steps for , Solana course but shoes this error message ,Please can you guide me to solve this issue

Welcome there,

What device are you using? Note that VSCode does not fully support the Apple M1 chipset.

I am a PC user OS is Ubuntu 22.04

Intel i5 is the processor

Unfortunately, I cannot think why that is happening, then. My only suggestion is to try running the course a few more times to see if it is intermittent.

Hello.

When running the solana curriculum for the first time the command to download the solana cli fails

When running the “solana --version” command later it is on 1.16.x not on 1.14.x

This carries over with errors

Later

    1. ✓ The validator should be running at http://localhost:8899.
    1. ✗ You should make an RPC call using curl.
    1. ✓ The RPC call should return a successful response. Try again

Step 2 returns false but somehow step3 is valid

Something is wrong there. Step 3 cannot run without step 2

Please help

If you are entering the correct command, this test failing suggests some files are not working as expected. How many Git changes do you have? I have seen a few instances from others where they had 100+ files with changes, and reverting the changes fixed the issue of some tests not working.

Hello

Could you please

  • Recommend a Linux Version on WSL that works for sure?

In Alpine the container runs, but some tests evaluate incorrectly

On Ubuntu 22.04 I haven’t even been able to open the container

Could we test and recommend an environment where it is guaranteed to work?

Thanks and best regards

Everything works more perfectly than imagined

Im already on lesson 22

One bug I found: when the container is being deployed it downloads solana 1.16.1 but then in the lesson browser it gives you instructions to download solana 1.14.1 because it assumes it is not installed yet. This causes a lot of problems and later it breaks many lessons

Tried running course again but still shows the same error
Do i have to do some changes in json as it prompting me…

@Badger5009

No, there should be no need to edit that, unless you are aware of device-specific changes you need to make.

Can you share the version of the Dev Containers extension you are using?

Also, double-check the error message in the terminal, the important part of the message appears to be further up than on the screenshot you shared.


@1pablo.escaida1

I have run the course dozens of times on:

  • Windows 11
  • WSL2 Ubuntu 22.04
  • Intel i7 10th gen

However, the whole point of the course running in Docker is it is supposed to be platform agnostic. The Docker image includes Ubuntu 20.04.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.