Solana Curriculum: unable to start course

Running on Windows 10.

I just tried to start the solana curriculum and after running " Dev Containers: Rebuild Container and Reopen in Container" there is no “freecodecamp: run course”-command as said in the manual. Also I get asked what kind of configuration I want, when I hit Dev Containers: Rebuild Container and Reopen in Container and there is no instruction what to choose.

@vincenthehna Either:
a) git clone did not work as expected (the .devcontainers folder is incorrect)
b) You are not in the correct workspace when opening VSCode

Would you mind sharing a screenshot or more info of what is displayed?

Also, I have moved your post to a new topic

I repeated the process 3 or 4 times now, never succeeded.
Screenshots show step by step. Like I said dev containers prompts me to choose a config, I dont know which one to choose. In the screenshots I went with nodejs+typescript.





It looks like you are opening the wrong workspace in VSCode.

You should open VSCode within solana-curriculum/ - not cd in the VSCode terminal once already open.

Hope this clarifies

I had tried both. Neither works :frowning:

ah ok I now opened VSC in the folder and did the dev containers Rebuild Container and Reopen in Container command. Now i can start the course. Its weird to me that there is a difference between “cd” into the folder or open VSC in the folder directly…
thanks for your help

I was unable to validate the following exercise

It maybe was not validating it I dont know but after upgrading the FCC extension it always returns the error page


export async function checkProgram(
connection,
payer,
programId,
accountPubkey
) {
if (connection.getAccountInfo(PublicKey).executable === false) {
throw new Error(‘Division by zero is not allowed’);
} else {
return ‘’;
}
}

This was my solution to the exercise