[SOLVED] Test results: false positive


I just got started on my responsive web design: tribute page challenge. I forked over the FCC codepen and as the Readme told me, I tried to run the tests to see that they all failed.
This is where it went wrong. I “passed” the test even though my tribute page is literally empty. Now I don’t know what to do since I won’t be able to actually test my page to see if it holds up. Maybe I uploaded the wrong link? Any help welcome!

I’m confused. I thought you said that the tests all failed. Did they pass with no content or fail?

Sorry for the wording. I meant that the readme in the pen said to run the test before you started, and that I would then see that they all would fail. Instead FCC told me that I passed (so no, I didn’t fail). Also, it was just the “you passed” screen, not the small round subsections of all the challenges.
Hope this clears it up a bit.

Just trying to make sure I understand…
You forked the empty project. Then you selected the test suite for the project you’re working on. Then you clicked ‘Run Tests’. And you got an indication that all tests passed?

I don’t exactly know what a test suite is? (sorry, very new to all of this)
This is the link to my pen:https://codepen.io/lisajongmans/pen/joMPLr
I just ran the test beneath the explanation of the tribute page project. I inserted the link to my pen in the solution box and clicked the button undeneath.
Thanks for the help either way.

The page that you put your link in doesn’t run tests. It just is the place where you submit the link. It’s your job to make sure that tests pass before submitting.

In your codepen, there’s a yellow box that says “Select Test Suite”. It has a dropdown menu for the project that you’re testing and it has a “Run Tests” button.

Oof okay I’m an idiot. Thank you so much! I’ll be on my way now :sweat_smile:

No worries. It’s all new for you. Happy coding!

1 Like