Test are passed in replit but not in freecodecamp

All 14 tests are getting passed in replit but when I try it in freecodecamp then not a single test is passed.


@BenGitter Could you please help me with this ?

Have you tried restarting your replit project? I cloned your project and all tests are passing for me.

Yeah, I tried restarting the project but same issue persists. All the tests are passed on replit but when I paste the url in freecodecamp not a single test is passed.

And you have set NODE_ENV environment variable to test?

Yeah, I’ve did that.

Do you get any errors in the node console, after running tests on project page?

This is what I get after running it on replit

I meant, once you press I’ve completed this challenge on the project page.

If I submit your project (https://boilerplate-project-issuetracker.kundan28.repl.co/) it passes all tests on freeCodeCamp. You might want to try another browser or maybe reset your browser cache.

It worked. Actually the issue was coming when the project was running on replit and when I tried stopping it and submitting the link on freecodecamp it worked.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.