I am not able to completely pass the challenge even though my 14 functional tests do actually pass, what can I do?

Hi all,

When I click on ‘I’ve completed this challenge’, I get this:

But if you look on my console, I AM passing all 14 tests:

What can I do in order to pass the ‘pass 14 functional tests’ test and therefore complete the challenge and move on? Is there something wrong with the way free code camp itself performs its tests or am I doing something wrong?

Thanks for your time


Your project link(s)

solution: https://replit.com/@jaimeggb/boilerplate-project-issuetracker


Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/93.0.4577.63 Safari/537.36

Challenge: Issue Tracker

Link to the challenge:

Looks like you might have not set NODE_ENV environment variable to test as needed.

1 Like

Hi @sanity

Thanks for your quick reply

When I do that, as shown:

None of the fcc tests pass, as shown:

But my 14 functional tests do pass on the console:

What could be happening?

Thanks for your time


Right now repl seems to be stopped, so that’s why all tests are failing. Try starting it again.

The failing test from the original post tries to access tests using _api/get-tests route. When page was still working I’ve tried that route and got response suggesting environment variable was not set. If it is set there might be something different going on.

Yes, the environmental variable was not set properly before (when you tried it) because I was experimenting to see what was going on.

So what is happening:

  • when I set the environmental variable CORRECTLY, my 14 functional tests pass the fcc tests, but none of the other fcc tests pass
  • but when I set the environmental variable INCORRECTLY, my 14 functional tests do not pass the fcc tests, but all the other ones do pass

Do you understand or would you like me to attach screenshots so you can understand better?

Greatly appreciate your help!


This isn’t the reason for the issue above, but it seems some of the tests are relying on the data that was entered outside of the tests. Particularly those regarding Test_project_2. Because of that forking code and trying to run it (with changed mongodb), to play around with it and try to reproduce problem, would need to change tests code at the start.

1 Like

I’ve changed some things in the test file for you @sanity :

so that you can fork the project and it will still work (I changed the tests that involved Test_project_2 amongst other things)

Thanks for your time!


Thanks, I haven’t had any specific issue with it now.

Every few runs there was one, in which, after finishing functional tests, page was no longer working. I don’t know why. However if after these tests, page was still working, it was possible to submit project without problems. So I guess you could try starting/stopping repl couple of times, until it still stable after functional tests and submit it then.

1 Like

Thanks for all of your help @sanity , thanks to you I finally managed to pass all the tests!

In the end what worked was going to MongoDB and deleting/‘dropping’ all of the issues from the database, then running my repl, and then finally clicking on the ‘I’ve completed this challenge’ button to pass all of the tests

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.