Tests don't run properly

Whenever I choose the option ‘Run the Tests’ after writing the code, nothing happens. If there’s something wrong with it then please fix it. Even for the simple hello world code, ‘Run the Tests’ option doesn’t work.

1 Like

I am experiencing same: Run Tests button never returns result

I have tried this on two pages and both never come back from running the test (10 min and counting). The bottom right pane just says, “// running test”



Same here, specifically with the Javascript Profile Lookup challenge. If I try to run it with something basic (like console.log(‘hi’):wink: it runs no problem (though obviously does not mark the challenge as completed). Then when I drop in my actual code, as follows, nothing happens…

for (i = 0; i < contacts.length; i++) {
if (name = contacts[i].firstName) {
return contacts[i][prop];
} else {
return ‘No such property’;
} else {
return ‘No such contact’;

Oddly, I have completed a couple of other earlier challenges today and did not have this problem with them. Just with this one.

Without the ‘Hint’ button, I can’t tell if I’m doing something wrong or if there are bugs causing some tests not to run properly. As Paul said, I completed several earlier without a problem. Some I am almost 100% positive they are correct and it still comes back with an error.


Same issue with three seperate tests. This is very upsetting as it has completely stalled my study and disrupted my study timeline.

Edit - I can safely say that this is the case with all tests. I’ve tried 10 seperate tests and all are failing at the //running test stage.

I study on my work laptop… could my outdated browser be the problem. I’m running firefox 38.1.0

I’m having the same problem - exercise gets to the //running test stage but doesn’t really do anything. This is very frustrating as I’m completely stalled.

Don’t see any solutions here - has anyone been able to resolve this?

Hallelujah! I just switched from Internet Explorer to Google Chrome and now my tests run!

Hopefully this will help someone else with this problem - try changing your browser.

I only wish I could… My work computer is locked so I can’t install other browsers. Glad this has worked for you though.

I use Chrome and it still doesn’t work sometimes. I have bunch of challenges incomplete because of that…

I just wanted to note that I’m also having this issue - I’m running the latest version of Microsoft Edge. Whenever I click “Run the Tests” the console box changes to ‘//running test’ and then stays that way.

Chrome may or may not have this issue, however I cannot tell because freecodecamp.org refuses to load on Chrome and always comes back with a timed out error, saying the website can’t be reached.

1 Like

I’m having the same issue here…I can’t get past first challenge and it appears code is correct. The page just sets there after selecting “run the test” with no result. Installed chrome with no avail. Any suggestions?

Having the same issue here also. Is this really “SUPPORT”? I can’t believe this hasn’t been fixed yet. Can a moderator help? Please???

Problems still exist, i have encountered my first situation where correct code ( I checked the hint just to make sure) can not pass the test because there is problem within the test. So, for me all the tests from the beginning (html/css) up to this particular one worked fine. This one is in Basic Js, and as you can see in output of console.log the proble m is that a variable is not defined which is defined, and by creators of the test (it is by default above the line where you need to change code).

I ask the person responsible for support to fix this problem, or at least reply to my message so that i can know that someone read it. If i have no reply in next 24h I will create a new topic on forum for this same problem.

EDIT (4/4/19): I tried it today, and the problem was fixed. Thanks to whoever did it! :slight_smile:

Did you ever figure out how to make run tests work? I’m on bing. So, I’m not sure wt problem is.

Don’t know man. I use Chrome, so when i have the time i do some challenges. But generally it happened few times that my code doesn’t work, syntax is fine, logic looks fine and i check the solution ( it is the same, only different var names), i copy/paste it and it passes all the tests ?!

I have just had an issue with “Understanding Case Sensitivity in Variables” in Basic Javascript course

I enter this as solution :
// Declarations

var studlyCapVaR;
var properCamelCase;
var titleCaseOver;

// Assignments

studlyCapVaR = 10;
properCamelCase = “A String”;
titleCaseOver = 9000;

Test returns this :

\ // running tests
studlyCapVar is defined and has a value of 10
Cannot read property ‘length’ of null
// tests completed

Something not working correctly?
Everything looks right in the code and the test response doesn’t appear correct to me?
Please help would really like to move on and get the certificate.

@JusB31ng, you have a typo for the first variable declaration and then you’ve carried that typo to the assignment for it.
The big X’s in the lower left show you how the variable should be spelled.

This is not a problem in the tests, you have console.log(product) as last line to code, product is a local variable and can’t be accessed outside of function, as such you were getting the correct response from the editor

When you do like that, before checking the hints, you may want to use the Ask for help button to ask to others what’s wrong with your code. You will be surprised what you can learn like that.

The correct one.Thank you for this info.