Trying to add glyphicons

Even though I can see the icons added correctly on localhost page, I am getting the following error:

GET http://localhost:8000/fonts/glyphicons-halflings-regular.woff2 net::ERR_ABORTED 404 (File not found)

After some googling, I found this solution:

So I tried to update web.config file. But - since I am no devOps (is that the right term?) expert, I could not find it. Which led me to this:

And now I am really lost.

My 2 questions:
1 - Will this be a problem when I deploy to my Github pages, i.e…the real world?
2 - If yes, what should I do?

Thank you!

What os is the server hosting your website?

Hmm - not sure I can answer that.

First, OS = operating system? If so, Github Pages is hosting my web page…and I have no idea what the OS of their server is…lol. I tried googling it but that wasn’t helpful.

You would only use web.config on a Windows machine.

Do you have your project on GitHub so we can test out the problem?

The browser is looking for fonts/glyphicons-halflings-regular.woff2 to be in the root folder of the website. Is it?

Here is it:

Again, page along with glyphicons show up OK. But error messages showing up in console.log. (You can ignore the message about DataMaps; that’s a separate issue that I forgot to fix before sending up files).

I don’t know where that root folder is…or how to get to it.

Thank you.

The source of the problem is you are using bootstrap vs 3.3.7 but only have the bootstrap.min.css file instead of the full library which includes many sub folders (including the applicable fonts folder) the bootstrap.min.css file references.

You can get the full version here by clicking on the Download Bootstrap 3.3.7 button or use a Bootstrap CDN like the one seen below:

<link rel="stylesheet" href="" integrity="sha384-BVYiiSIFeK1dGmJRAkycuHAHRg32OmUcww7on3RYdg4Va+PmSTsz/K68vbdEjh4u" crossorigin="anonymous">
1 Like

Thanks - that was it exactly. Fixed on localhost page for now.