Twitch Viewer used to work, did something change?

Twitch Viewer used to work, did something change?
0.0 0

#1

I had my project working fine (http://codepen.io/JKatras/full/aNRbXw/), until I happened to check it today and all users are shown as not existing now. Checking some of the older projects on CodePen, it looks like a lot of people are having the same problem.

I don’t see any error in console except Uncaught ReferenceError: $ is not defined - contentscript.js:21 which seems to be on CodePen’s side.

Does anyone know if something changed with the Twitch API?


Twitch Tv api - can't retrieve any data from the link i request
#2

#3

Hey,

Your error probably comes from https://blog.twitch.tv/client-id-required-for-kraken-api-calls-afbb8e95f843#.rfbnmghng

It shouldn’t take long to fix :slight_smile:


#4

There is also already a issue on FreeCodeCamp’s github: https://github.com/FreeCodeCamp/FreeCodeCamp/issues/10740


#5

Thanks for the info!


#6

So, now we have to setup a Twitch account, too?


#7

Hmm… I sense this project is on its way out. No big loss, I’m sure Quincy and co. will come up with something even better.


#8

I believe so. You now need a client ID that is registered to your application, which I think is only given to registered users, unless someone knows otherwise.


#9

Can’t say I was a fan of that API anyway.


#10

It seems anyone can register, but you need a URI for the app, which I don’t think can work with Codepen. If that’s true, it pretty much sinks this project for FCC.


#11

You can put localhost:3000 (or basically anything) in that field.


#12

I use my localhost address but it still works as usual on codepen.


#13

According to this: https://github.com/FreeCodeCamp/CurriculumExpansion/issues/46, you sense right :wink:

Note: Simon, Tic Tac Toe, Twitch, Wikipedia Viewer, Local Weather, Roguelike Dungeon Crawler, Markdown Previewer and Camper Leaderboard will become just some of many bonus practice projects.


#14

Can’t believe they’re getting rid of tic tac toe! Just finished that project and its got the most challenging algorithms out of any of the front end projects. Definitely a good one to do as a bonus project.


#15

Are you saying that your app works now after you followed the suggested steps and setting your URI to localhost?
It didn’t work for me.


#16

@alphaoliveira Yes it did work worked after i added the client Id…As instructed they said to put the client Id in your ajax request as a header option but that didn’t work after I tried it… so I put the client id in the urls I used to make the requests like shown below and it worked…if I removed the header option in the request, it will still work but I left it just incase.

$streamApiUrl = "https://api.twitch.tv/kraken/streams/" + streamers[i] + "?client_id=YourId&callback=?"

    $.ajax({
      type: "GET",
      dataType: "jsonp",
      url: $streamApiUrl,
      headers: {
       'Client-ID': 'yourId'
      }

Designed a new portfolio -- again! Would love critiques :)
#17

I’m really glad the dungeon crawler is not going to be required anymore. It’s the only thing standing in the way of me getting the data-viz cert, and frankly it’s never been an appealing project to me.


#18

It works now, thank you very much.


#19

No problem…glad to hear it did :smiley:


#20

Hi Azdrian,

I have read the problems that people had with twitchTV and before I dig into it I am visiting examples on codepen and it seems like if nobody was ever connected., take as an example… https://codepen.io/FreeCodeCamp/full/Myvqmo/

Is this normal? I would hate to waste time on a deprecated Api.

Thanks,