Unable to download external modules. Showing modulenotfounderror. Please tell me about it

I have downloaded pyttsx3 in pip but I am not able to use it.
Python is showing ModuleNotFoundError
I am stuck because this error is occurring only in IDLE and visual studio 2019, when I tried running it in spyder and jupyter notebook it worked.
Same problem is happening with tensorflow and pytorch as well.
Please help :frowning:

This is because you’ve installed pyttsx3 and other modules in anaconda environment, and since Jupyter, Spyder are installed with anaconda, they are using anaconda environment…
But your Visual Studio and IDLE are using the system environemnt, means your main python environment…
In Visual studio, I think there’s an option to change default interpreter path, otherwise you can install required modules in the main environment…

1 Like

Thank you but please tell me how to download modules in main environment.

install packages using pip install package-name in your cmd
check this page for more details

Please do me a final help :pray::pray:
Tell me how to create a system main python virtual environment that will install modules in python path.
Thank-you for helping me with my problem.

No, I was not talking about main virtual environment, actually I was unable to explain​:weary::weary:… Just type pip install pyttsx3… I guess it should be installed in main environment.