Unable to use any other language when developing on Gitpod

Whenever I choose a language from menu or just try to add /espanol/ or any other language path to the browser, I get an error.
I was trying to debug for 2 hours and wasn’t able to.
I hope someone can explain why it is like that, I checked all config files, or onRedirect, or I would even say all files from codebase already and still unable to get it :smiley:
It looks like the translated page is sent later according to browser console, via some webpack-runtime. So I assume it somehow works only on the production website? Most likely I’m just missing some step which I couldn’t find in the docs or something.

Welcome there,

Have you followed these instructions: Contribution Guidelines | freeCodeCamp.org

If not, you need to build the client app in the language you want to test. As it stands, without a lot of set up, it is not possible to develop the client with all languages built for the language menu to work.

Hope this clarifies

Sorry, I checked it before and tried it, but for some reason it didn’t make sense to me then. Checked it once again and now it works. Just need to run pnpm run clean-and-develop after putting the needed language at the top of those objects.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.