Using the "option" key on mac - Relational Database Course

Hello :slight_smile:

I am having trouble using the “option” key on mac while using the CodeAlly console, it seems silly but it’s a problem since I can’t create “[” or “”…

Did anyone also encountered this problem ? I tried searching for an answer using the search bar but nothing came up.

Thank you !


Certain shortcuts keys can get overridden by your browser or potentially your operating system. I’m not sure I understand why you need the option key to enter [. Why not just hit that key. Let me know if I am misunderstanding something.

Hey! Thank you for answering. Sorry that was my mistake not explaining all the context (did not think it was important).

I did not know you could just hit [ on Qwerty keyboards… Since I have a French keyboard (Azerty), I need to enter option + Shift + ( in order to make " [" or "\ ", so it is quite problematic.

EDIT: Thank you for your time and suggesting I use “only” the keyboard !

I found out that in mac you could change your keyboads settings easily by using the “fn” key. I just created a new Qwerty keyboard and used it like that. My problem is resolved but I believe most of the Europe people will have the same problem since we don’t use the Qwerty Keyboards.

1 Like

There’s some discussion around a similar issue here. Their solution was “I changed my keyboard layout to US, now it works.”