You must install peer dependencies yourself. in reactnative

You must install peer dependencies yourself. in reactnative
0.0 0

#1

I am creating a new react-native project, I am installing npm packages,I already installed
npm install -g install-peerdeps after that I taken the project i.e cd manager and I installed
C:\Users\nagaraju\manager>npm install --save react-redux redux
npm WARN gentlyRm not removing C:\Users\nagaraju\manager\node_modules.bin\jest.cmd as it wasn’t installed by C:\Users\nagaraju\manager\node_modules\jest
npm WARN gentlyRm not removing C:\Users\nagaraju\manager\node_modules.bin\jest as it wasn’t installed by C:\Users\nagaraju\manager\node_modules\jest
npm WARN gentlyRm not removing C:\Users\nagaraju\manager\node_modules.bin\uglifyjs.cmd as it wasn’t installed by C:\Users\nagaraju\manager\node_modules\uglify-js
npm WARN gentlyRm not removing C:\Users\nagaraju\manager\node_modules.bin\uglifyjs as it wasn’t installed by C:\Users\nagaraju\manager\node_modules\uglify-js
npm WARN gentlyRm not removing C:\Users\nagaraju\manager\node_modules.bin\json5.cmd as it wasn’t installed by C:\Users\nagaraju\manager\node_modules\json5
npm WARN gentlyRm not removing C:\Users\nagaraju\manager\node_modules.bin\json5 as it wasn’t installed by C:\Users\nagaraju\manager\node_modules\json5
npm WARN gentlyRm not removing C:\Users\nagaraju\manager\node_modules.bin\esparse.cmd as it wasn’t installed by C:\Users\nagaraju\manager\node_modules\esprima
npm WARN gentlyRm not removing C:\Users\nagaraju\manager\node_modules.bin\esvalidate.cmd as it wasn’t installed by C:\Users\nagaraju\manager\node_modules\esprima
npm WARN gentlyRm not removing C:\Users\nagaraju\manager\node_modules.bin\esparse as it wasn’t installed by C:\Users\nagaraju\manager\node_modules\esprima
npm WARN gentlyRm not removing C:\Users\nagaraju\manager\node_modules.bin\esvalidate as it wasn’t installed by C:\Users\nagaraju\manager\node_modules\esprima
npm notice created a lockfile as package-lock.json. You should commit this file.
npm WARN react-redux@5.0.6 requires a peer of react@^0.14.0 || ^15.0.0-0 || ^16.0.0-0 but none is installed. You must install peer dependencies yourself.

  • redux@3.7.2
  • react-redux@5.0.6
    added 5 packages, removed 697 packages and updated 18 packages in 60.62s

C:\Users\nagaraju\manager>react-native start
Command start unrecognized. Make sure that you have run npm install and that you are inside a react-native project.

C:\Users\nagaraju\manager>
how to solve this issues… please help me